• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2022
  • Last Modified:

O365 Accepted domains shows Authoritative and needs to be Internal Relay but grayed out

Hello EE,
Users cannot email our .eu office and I found it is because the domain is listed as Authoritative under Admin > Mail Flow > Accepted Domains and it's grayed out so I can't change but I need it to be internal relay.  Please help.
1 Solution
Muralidharan RAssociate ConsultantCommented:
James HodgeManaging DirectorCommented:

Can you change it via a remote shell?
Set-AcceptedDomain contoso.com -DomainType InternalRelay



Authoritative Accepted Domains uses:

whenever a user receive any email which is belongs to this same Authoritative domain. It comes like this.

From remote (Gmail or any) domain >> then it will go to Exchange >> then Exchange will query to AD whether the user is listed or not.  AD replies the user is not their in my list.
Exchange will generate DSN which means, NDR.

Suggestion, first of all delete that and recreate a new one make sure select internal relay option.

Otherwise stopped MS Transport service and make the changes.

Thank You!
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

bergquistcompanyAuthor Commented:
@James: Tried that but getting: A positional parameter cannot be found that accepts argument -DomainType

@Mohd I cannot delete as it says some users are using it.  Plus just added a test and don't have an option through the web to pick internal relay.  If I stop MS Transport service where can I make the change in the web interface will it not be greyed out?
James HodgeManaging DirectorCommented:
I would give the support a call at this stage.
bergquistcompanyAuthor Commented:
Trying here because support has no idea :)  Thought maybe somebody ran into this before
bergquistcompanyAuthor Commented:
Found we were stuck in upgrade mode
bergquistcompanyAuthor Commented:
had to go to support
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now