Exchange 2010 Public Folders: Adding Permissions for a Group

We are running Exchange 2010. I am trying to add a new "Domain Local" Security group to a public folder's permissions.

But when I click Add I am not seeing the AD group as an option. Why not?
Who is Participating?
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
To use permissions in Exchange the group needs to be mail enabled.

David Paris VicenteConnect With a Mentor Systems and Comunications  Administrator Commented:
You probably will have to change the recipient Scope.

Please follow this tech net: Mail enabled security Groups

And for change the recipient scope: Change recipient scope

Please advise if worked for you.

Md. MojahidConnect With a Mentor Commented:
please assure the Security Group scope is under Universal. Also, please refer to the following article to mail-enable a Security Group.
pzozulkaAuthor Commented:
Thanks all. I had to mail enable the group, but couldn't find it from the pick-list when trying to add an EXISTING group -- I even tried changing the scope but that did not help. Finally I made the group Universal, added a new Distribution group selecting my security group as an existing object (found it no problem). Then was able to add it to Public Folder permissions.

Lastly, went into AD and changed it back to Domain Local. :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.