• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4180
  • Last Modified:

Exchange DAG fails because of sector size does not match


My dag on exchange 2010 sp3 fails because

"The log copier was unable to continue processing for database 'mb03-data01\TITAN-EX-A-MB03' because an error occured on the target server: Continuous replication - block mode has been terminated. Error: the log file sector size does not match the current volume's sector size (-546) [HResult: 0x80131500]. The copier will automatically retry after a short delay."

I got two servers running windows 2008 R2 on hyper-v 3.

The VHD files on the servers are dynamic .vhdx disks.

If i look with "fsutil fsinfo ntfsinfo" on the disks for the loggfiles i got different result, on the "sending" DAG member i got
Bytes Per Sector  :               512
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024

And on the reciving
Bytes Per Sector  :               512
Bytes Per Physical Sector :       4096
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024

Does anyone know what is causing this differance or a workaround for it?
2 Solutions
mattemattssonIT ProAuthor Commented:
Hello, thanks for your assisting help! It was the storage drivers that had to be updated on the servers, i ran the VM integration disk and upgraded the drivers and now it works :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now