Windows Server 2012 stop registering DNS on second/third IP

I have 2 Windows Server 2012 DCs that are running DNS as well as NLB.  Each server has 2 active NICs, one for normal traffic and one for the NLB. Even though I uncheck the box to register this connection for either one or both of the NIC cards, it keeps registering all addresses in DNS.

Server 1: FS1
   NIC 1 - Normal Traffic:  IP 10.10.1.1
   NIC 2 - NLB: 10.10.1.22

Server 2: FS2
   NIC 1 - Normal Traffic: IP 10.10.1.2
   NIC 2 - NLB: 10.10.1.23

Both servers are registering the address for NIC 1 and NIC 2 as well as the NLB cluster address of 10.10.1.21

I only want the NIC 1 address for each server listed in DNS (which I can manually create).

I have tried setting the "skipassource" flag on the NIC2 and the NLB cluster address on each server using PowerShell and then delete the hosts from DNS server and they keep returning.
degemberlingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

degemberlingAuthor Commented:
I may have finally solved this issue that has plagued me for several weeks. I found the articles below that pointed me in the right direction.  I was basically troubleshooting this issue from the NIC end of things.  The issue was actually being caused by the DNS server itself. I used method 2 in this article to point me in the right direction:



The Host's "A" Record Is Registered in DNS After You Choose Not to Register the Connection's Address

I am waiting to see if the Host A records stay out of the DNS now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
degemberlingAuthor Commented:
It appears that setting DNS Server to only listen to NIC 1 removed the unwanted A Host records from DNS.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.