Wireless access to wired network

Hello all,

I have recently set up a Sonicwall tz-100 wireless router/firewall on a wired network.  We have one laptop that needs to connect to a windows media server that is on our wired network.  The laptop can browse the internet as I have a policy that allows the wireless 172.x.x.x network to get to my wired 192.x.x.x default gateway.

What else do I have to do to get access to the files on the 192. network?

Thanks!
SapeurAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

R. Andrew KoffronCommented:
You should just be able to make a Network Access rule to allow the WLAN to access the zone the media server is in.
0
JaniLSCommented:
On the Sonicwall, I think the wireless wizard would give you that option during setup but none the less do the following:

On the zones tab:
Check box to make WLan (wireless LAN) zone trusted

under the firewall tab:
Make rule for Wlan => Lan       allow - any service
Make rule for Lan => WLan      allow - any service

Also there is a check box within the wireless settings to allow net bios traversal which is helpful for your wireless clients to act as though they are on the lan.

Make sure within the DHCP settings for the wireless network's IP Range (172.xxx.xxx.xxx) that you specify the domain dns server on the DNS tab within DHCP so that your clients can find servers and PCs on the LAN.
0
Blue Street TechLast KnightCommented:
Hi Sapeur,

You can simply setup Access Rules as @JaniLS described or setup an L2 bridge so that LAN & WLAN are on the same subnet: https://www.fuzeqna.com/sonicwallkb/ext/kbdetail.aspx?kbid=7081.

I prefer the Access Rules route personally.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

JaniLSCommented:
If you bridge the wireles interface with the Lan interface, you do not end up with seperate zones and wireless clients will recieve 192.xxx.xxx.xxx IPs. They will be on the LAN from the prospective of the firewall, much like a traditional access point.

I have never tried to accomplish this on a tz100 and do not know if they even have the capability?

The rules are quick and easy.
0
Blue Street TechLast KnightCommented:
@JaniLS - Yes, you are correct, that is the idea of an L2 Bridge! See the SonicWALL KB article...it's supported & easy.

But I agree with you I prefer the Access Rules. I was just giving Sapeur some options! ;)
0
SapeurAuthor Commented:
All of the firewall settings are correct.  The problem here is that the previous I.T. company set them up on windows Media server, ugh!  They will be on a domain shortly as I have set up a server for them.  However for the next week or so they need access with the current set up.

I can ping the laptop from one of the pc's on the 192.168.0.0 network.  But I cannot ping any pc's on the 192.168.0.0 network from the laptop which has a 172, address.  I can however ping the comcast modem on the other side of the Sonicwall.  The comcast internal ip which is 192.168.1.254.  So, traffic is getting from the laptop through the sonic wall.  I have a feeling that it's something to do with limitations of Media server's networking capabilities.  I did read something about homegroup computers having to be on the same subnet.  Perhaps diverseit's L2 bridge ideas is my only option.  Any other ideas?

Thanks
0
Blue Street TechLast KnightCommented:
I see.

Have you checked or disabled the Windows Firewall for testing purposes...maybe ICMP is not enabled?
0
SapeurAuthor Commented:
Ok, here is the latest on this:

I can ping the server from the laptop but I can't map any drives.  This is looking more and more like a windows media server/homegroup problem.  Your thoughts?
0
SapeurAuthor Commented:
Just saw your above posts, sorry been crazy busy.  I'll try the L2 bridge idea and keep you posted.  Thanks!!
0
Blue Street TechLast KnightCommented:
Sounds good!
0
SapeurAuthor Commented:
Access rules would be preferable I agree.  However, Media server requires bridging so Wlan and wired lan are on the same subnet.  Thanks!!!
0
Blue Street TechLast KnightCommented:
I'm glad I could help! Thanks for the points.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.