Inaccessible web image

We have a very strange problem to which we have uncovered no potential cause or solution.

Our site has a gallery.  When an image is added to the gallery, workstations at the office location can not load the gallery page--the browser never loads the page.  We have tried IE, Chrome, and Firefox, both Windows & Mac workstations.

However, at my house and other computers, the page loads with no issue.

When the image is removed, the gallery loads (this is a new problem, no changes have been made to the gallery code) for the office workstations.

If the image is loaded outside of the gallery (embedded in a test page), the page does not load for the office, but does load outside of the office.

If the image is converted from JPG to PNG for the test page (gallery uses JPG), the page loads for the office.

I've looked into the router situation and nothing suggests the blocking of an image.  Not that it would make sense that adding an image would cause the problem for one specific problem.

Here is an example: http://goo.gl/URQ8sU

This page does not load for any office workstation, it loads fine for me outside of the office.  If the last image is removed, the page loads.

Are there any thoughts regarding what could be causing this strange occurrence?
LVL 1
dageyraAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kent DyerIT Security Analyst SeniorCommented:
Something in your reverse proxy or firewall rule?  I am guessing a bit here..

Proxy would make sense as it operates kind of like a caching system.

HTH,

Kent
0
GaryCommented:
Hard to debug something we cannot see going wrong.
If you put that table into its own page does it still fail to load.
This is basically a case of testing each part of the page to see if you can find the glitch
Is there anything there in view source?
If you have FF try HTTPFox to see the resources being loaded
0
dageyraAuthor Commented:
Thanks Kent, we aren't using a proxy.  I assume you mean at the router level?  I don't even know if the router firewall can be disabled temporarily to check.  The firewall basically blocks everything except certain services that it allows in, but I'm not sure how that could be blocking this one specific image.  The page loads if this one image is removed.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

dageyraAuthor Commented:
I agree Gary, it's very frustrating as I work remotely and it works perfectly for me.  I have RDP access to the office workstation, must wait until after 5 when everyone clears out.  I could perhaps do a remote assistance request?

I don't have to put the entire table, just the image (we had a similar issue last week, I wrote it off to some kind of image glitch).

Here is a test page I created:

http://ryan.neoterichovercraft.com/test1.html

This page has only the embedded image, nothing else in the source, and does not load from any office workstation, but it does load for me outside of the office.  They use firefox and the page just never loads (I assume eventually it would timeout).  If you have any troubleshooting steps, suggestions to lookup in the router, I can look into that.
0
Tom BeckCommented:
Just a minor observation. When you add that last image, it goes to the second row of the table. If it's the only image in the row, the <td> should have a colspan attribute like <td colspan="3">. Can't imagine why that might be causing the problem described, but I've seen stranger things happen.

Also, if you look at the source in Firefox you will see several red tags indicating other html syntax errors. This page would not pass a validation test. I'd fix all the errors and see if that takes care of the problem.
0
dageyraAuthor Commented:
Hello tommyboy, I created a test page with only the image to demonstrate that the problem is related to the image:

http://ryan.neoterichovercraft.com/test1.html

There should be no syntax errors in that page.

If the source image on that same page is replaced to any of the other images in the gallery, it loads fine in the office and outside.
0
GaryCommented:
And can you access the image directly in the browser i.e. not an html page just the path to the image.
This will eliminate the obvious, if it doesn't load then your code is fine and something else is blocking the image.
Which specific image is it?
0
dageyraAuthor Commented:
Here is a screenshot of the test page from an office workstation provided by an employee.  This was after 30 seconds, in Firefox.  You can see it's waiting to load the source image from the photo gallery.
neoteric-image-load.png
0
dageyraAuthor Commented:
Gary, thanks for the reply, and no they cannot load the image directly.
0
GaryCommented:
You have FF so install the HTTPFox plugin, you can then see any errors with the image loading (hopefully)
Can they test in another browser
0
GaryCommented:
That looks like a broken image tag...
0
dageyraAuthor Commented:
Thanks Gary, I don't really know how to interpret any of the HTTPFox.  Here is a screenshot taken about 30 seconds after loading the test page.
phototimeout.png
0
dageyraAuthor Commented:
What is a broken image tag?
0
dageyraAuthor Commented:
Here is a screenshot of HTTPFox when attempting to directly load the image.
photodirecttimeout.png
0
Dave BaldwinFixer of ProblemsCommented:
Your gallery images are on a different subdomain.  Any chance that it is blocked?

http://photos.neoterichovercraft.com/galleries/Building/TuyetNga/thumbs/03tuyet09septembet2013.jpg
0
dageyraAuthor Commented:
Thanks Dave, no other images in the same gallery load fine.  If that one image is taken down, the page and gallery works.
0
Tom BeckCommented:
If it's just that one particular image then maybe it's the image itself. Maybe there's some minor corruption in it and the firewall at the office has a problem with the reported mime type or something. I've seen our firewall block parts of web pages for header irregularities that load just fine outside of our network. If you can save as a png and it works that way then save it as a new jpeg and see if that works. Or save as a png and then save the png again as a jpeg.
0
dageyraAuthor Commented:
Here is a screenshot from the same workstation with a different image from the gallery, it loads with no issue.
imageworking.png
0
GaryCommented:
While running HTTPFox can you do a hard refresh on the image and paste a screenshot
Under the content tab check if its full of gobbledygook
0
dageyraAuthor Commented:
Thanks tommyBoy, I downloaded the image and saved as a PNG.  After that, the test page (updated to use PNG) loaded.  I then saved the PNG as a JPG and created a test page to use the new JPG.  It loaded fine.

So there is something about the original JPG, but what could it be?  How to determine?
0
dageyraAuthor Commented:
Hello gary, I can do a screenshot but it says "Type:" under the content tab and in the textbox it only says "Not ready..."
0
GaryCommented:
Did you try clearing the cache?
0
dageyraAuthor Commented:
Gary, yes I have cleared the cache.  Did you mean for me to run HTTPFox on that image you specified?  That one works.  I went ahead and did it for both images.  The first image loads, the second image is the image in question and does not load.

I showed the content tab for both.
httpfox-imageworking.png
httpfox-imagenotworking.png
0
dageyraAuthor Commented:
I got the source image from the camera (not going through the photo gallery upload) and did a test with it.  The same problem occurs, the image does not load from within the office.

This tells me the corruption must be at the camera? Maybe too old, broken down, etc?  It's a basic digital SLR, but it is many years old.  Before I take this to the client, does it sound feasible based on the tests performed?
0
GaryCommented:
Something is happening to the image before it gets to the browser.
Suggestions - disable firewall, AV and any ad blocking software and see if loads.
If none of them then all I can suggest is look at the router again.
0
GaryCommented:
Since it is only in your office that it cannot be loaded I doubt it is anything to do with the camera, the image loaded up fine in PS and that would usually say something if there was any corruption
0
dageyraAuthor Commented:
We tried it on a Mac that has no antivirus or ad-block, firewall disabled, and it had the same issue.  What would cause an image block in the router?  It works for one image, on the same server--the same directory on the server even--but not another.  

Also the fact that the image which fails can be converted to PNG and back to a JPG, and then start working perfectly.  That indicates something is wrong with the source image. However, I'm skeptical about corruption because I downloaded a JPG checker utility and it says the image is OK, no error or warning,.
0
Dave BaldwinFixer of ProblemsCommented:
What router do you have?  My Comcast router/modem has a built-in firewall and content filter and I had to turn that off to allow some files thru it.
0
dageyraAuthor Commented:
Progress! I went through the router, doing a more in-depth study of features.  Most (QoS, access policy, etc) were disabled but the IPS was enabled.  This is a threat detection against worms, buffer overflows, etc. It also blocks services like p2p, IM, etc.  I disabled it and the page loaded!

So why is the IPS catching on this image?
0
dageyraAuthor Commented:
We have a Cisco WRVS4400N.  I found out what is blocking the image, but why is it blocking it?  And not other images from the same source?
0
dageyraAuthor Commented:
More progress!  I went through the IPS options to see if it could still be enabled and figure out exactly what is blocking the image.  I've worked out that the ICQ option under Instant Messenger is the culprit.  If this option is left blocked, the image does not load.  As soon as it's un-blocked, it loads.

Any thoughts?
0
GaryCommented:
Something in the binary it thinks is suspicious...
0
dageyraAuthor Commented:
I found the IPS log, it even shows that our server has been making 'CHAT ICQ login attempt'.  Any thoughts why an image be coming through as an ICQ login attempt?  At this point I can take the problem straight to cisco perhaps.
0
GaryCommented:
The router would be examining the binary data, something about the data must look like an ICQ request.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BillDLCommented:
I have a suggestion, dageyra, and that is to use a utility to strip out all superfluous metadata from the JPG images that you are using on that website, including the problematic one.  Web browsers don't read all the EXIF, IPTC, and ICC tags, or software-specific data created by applications like PhotoShop, anyway.  There is loads of other data in images created by the main camera manufacturers (and occasionally also data written when image transfer utils are used to get the images from cameras) that is nothing more than bloat in images used only on standard web pages.

One such utility is JStrip by David Crowell.
http://davidcrowell.com/jstrip/
http://davidcrowell.com/download/jstrip.zip

Pretty simple to use.  Just install and choose the "Custom" option, and only tick the "core files" and optionally the "command line client exe" if you are used to using "DOS" commands.
Run it and choose File menu > "Options".
Most are self-explanatory and are just preferences, but under the "JPEG" tab of the options, I would suggest that you tick all boxes EXCEPT for stripping out the "JFIF Header".  Modern web browsers identify files by the contents rather than by their extensions, and although the data should be identified as an image, the JFIF header in a JPG file reinforces identification.  To my knowledge browsers disregard the rest of the data described by the tick boxes.
Choose the image(s) (or complete folder if you preferred that option) and click "Start".

Original EXIF date in your file: http://photos.neoterichovercraft.com/galleries/Building/TuyetNga/photos/03tuyet09septembet2013.jpg as obtained using IrfanView image viewer and editor:
Filename - 03tuyet09septembet2013.jpg
Make - NIKON CORPORATION
Model - NIKON D40X
Orientation - Top left
XResolution - 300
YResolution - 300
ResolutionUnit - Inch
Software - Ver.1.00
DateTime - 2013:02:09 12:35:34
YCbCrPositioning - Co-Sited
ExifOffset - 216
ExposureTime - 1/30 seconds
FNumber - 3.50
ExposureProgram - Not defined
ISOSpeedRatings - 220
ExifVersion - 0221
DateTimeOriginal - 2013:02:09 12:35:34
DateTimeDigitized - 2013:02:09 12:35:34
ComponentsConfiguration - YCbCr
CompressedBitsPerPixel - 2 (bits/pixel)
ExposureBiasValue - 0.00
MaxApertureValue - F 3.48
MeteringMode - Multi-segment
LightSource - Auto
Flash - Flash not fired, compulsory flash mode
FocalLength - 18.00 mm
UserComment - 
SubsecTime - 90
SubsecTimeOriginal - 90
SubsecTimeDigitized - 90
FlashPixVersion - 0100
ColorSpace - sRGB
ExifImageWidth - 3872
ExifImageHeight - 2592
InteroperabilityOffset - 26224
SensingMethod - One-chip color area sensor
FileSource - Other
SceneType - Other
CustomRendered - Normal process
ExposureMode - Auto
White Balance - Auto
DigitalZoomRatio - 1 x
FocalLengthIn35mmFilm - 27 mm
SceneCaptureType - Standard
GainControl - None
Contrast - Normal
Saturation - Normal
Sharpness - Normal
SubjectDistanceRange - Unknown

Maker Note (Vendor): - 
Data version - 0210 (808595760)
ISO Setting - 220
Color Mode - COLOR
Image Quality - NORMAL
White Balance - AUTO
Image Sharpening - AUTO
Focus Mode - AF-A
Flash Setting - 
Flash Mode - 
White Balance Adjustment - 0
White Balance RB - 674
Exposure Adjustment - 0.0
Thumbnail IFD offset - 2694
Flash Compensation - 67072
ISO 2 - 220
Tone Compensation - AUTO
Lens type - AF-D G
Lens - 758
Flash Used - Not fired
AF Focus Position - 33751048
Bracketing - 65536
Color Mode - MODE3a
Light Type - NATURAL
Hue Adjustment - 0
Noise Reduction - OFF
Total pictures - 41539
Optimization - 

Thumbnail: - 
Compression - 6 (JPG)
XResolution - 300
YResolution - 300
ResolutionUnit - Inch
JpegIFOffset - 26364
JpegIFByteCount - 8744
YCbCrPositioning - Co-Sited

Open in new window

is all removed by JStrip, but the file is still a standard JPG that will display normally in web browsers.

You would obviously only do this to COPIES of your original images that are ONLY used for the site, and it would entail uploading them again by FTP and allowing them to overwrite the ones currently on the web server.

If you have control of the FTP upload to the web server, choose "Binary" or "Auto" and not "ASCII" as this can screw up images during the transfer.

Strangely enough there is an instance of "ICQ" in the binary data of your image, but in a hex editor it is in reverse as shown.  Whether or not this was detected is something I couldn't guess about, but I would have thought that a detection like this would be so overzealous that it would have blocked many more files.
Note: this is amongst data removed by JStrip.
0
dageyraAuthor Commented:
Thanks for your help guys.
0
BillDLCommented:
Thank you dageyra.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Images and Photos

From novice to tech pro — start learning today.