Windows firewall issue with port 443

I am trying to telnet to my server on port 443.

I have a utility listening on port 443.

I have an Inbound windows firewall rule allowing traffic on port 443.

I also have other inbound firewall rules on other ports.

I can successfully telnet on my other ports.

I get no response when I try to telnet on port 443.

I turn off the windows firewall and then I get a response on port 443.

Any idea what would be causing windows firewall to block port 443 even though there is a firewall inbound rule allowing it?

Thanks, Kevin.
Who is Participating?
kevinvw1Author Commented:
Even though there was an inbound rule for port 443 already in the firewall (World Wide Web Service (HTTPS traffic in))
I still had to create another inbound 443 rule and then it worked.
Dave BaldwinFixer of ProblemsCommented:
On my computer, port 443 is opened for Secure Web Server Access (HTTPS).  Telnet does not do 'HTTPS' so maybe that is why.
kevinvw1Author Commented:
It was not the protocol that was the issue it was merely the port.

Telnet works fine to just let you know that port 443 is listening.

I just successfully tried it on Windows 8 and Mac OSX.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.