SBS 2011/Exchange 2010 Opening up Relay to Exchange Server

Hi, I recently installed a new SBS 2011 Server migrated from an SBS 2003 etc.
Everything is fine apart from their Line of Business Database program isn't sending out their emails but email sends out fine as normal for Outlook etc.

I don't have much information on the database apart from the fact it points to the internal IP Address of the SBS server and uses port 25 and runs on their workstations with the data actually running live across their network but is actually held on the SBS Server.

I've advised the customer bulk email sending isn't really recommended via Exchange server these days because of spamming / potential blacklisting etc as I believe the database uses their internal Exchange Server to send out several thousand emails but it always worked before on their old SBS 2003.

I've tried setting up a new “New Receive Connector” within Exchange Console under Server Configuration and Hub Transport.
Gone to "Receive mail from from remote servers that have these IP Addresses.
and put in their internal DHCP scope range that their client PC's use i.e. 192.168.x.10 - 192.168.x.200
Gone to authentication and ticked "TLS" and "basic authentication"
then permission groups and ticked "anonymous access"

Got them to try from a client PC sending again but all the database says is "socket error"
it's quite an old and outdated bit of software and isn't very configurable in terms of it's SMTP settings.

Would appreciate if anyone has any ideas on this or if there is something I might be missing??

Many Thanks in advance.
LVL 1
CRL ltdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
SBS by default will block access to the local network for sending email to Exchange.
Does the application need to send to external recipients, or just internal?
If just internal, enable anonymous on the Default Receive Connector and then restart Transport.
If it is need to send to external recipients, then you need a new connector as you have created but it needs some additional settings.

Follow the guide on this blog posting - it is for Exchange 2007 but the commands the same on Exchange 2010: http://semb.ee/apprelay

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CRL ltdAuthor Commented:
Their application needs to send to external email addresses.
I've tried setting it as per Option 2: Grant the relay permission to Anonymous on your new scoped connector

hopefully this will do it I will get them to test tomorrow.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.