Allowing and checking port open in windows 2012

I'm trying to open a port for a particular program. This program is Sonicwall SSO agent which communicates through port 22xx. I installed it and the gateway was not able to access through it. So, I checked firewall on the server it has the agent installed. The program was not in firewall rule. So, I added the program to the firewall, still no luck.
So, I manually configured inbound rule to open the port 22xx with wide open for domain, private, pulbic, and all remote clients'. Then, when I telnet to the port 'telnet x.x.x.x 22xx', it failed.

I ran 'netstat -a' on the server to see if the port is open, it doesn't list the port that I added to firewall.

How do I open the port and see what port is open on the local server?
LVL 1
crcsupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dipopoCommented:
You can use nmap to check open ports on a server.

http://nmap.org/download.html

And to check your new rule use.

netsh advfirewall firewall show rule name="new rule" verbose
0
David AtkinTechnical DirectorCommented:
Do you have any anti-virus or anything that would be blocking the port as well as the firewall.

NMAP as previously suggested is a good tool for checking the port status.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blue Street TechLast KnightCommented:
Hi crcsupport,

Is the agent running on the server where the Domain is running?

You indicate you're using port 22xx. You must use port 2258. Can you verify that?

SonicWALL SSO agent tries to identify the logged in user by querying the workstations using NETAPI or WMI protocols. NETAPI and WMI require "file & print sharing" enabled on the end workstations. Do you have that set?

Also verify you have installed the agent per this Article: https://www.fuzeqna.com/sonicwallkb/ext/kbdetail.aspx?kbid=5948

Here is how to configure it properly on the server: https://www.fuzeqna.com/sonicwallkb/ext/kbdetail.aspx?kbid=5949

And here is how to configure it properly on the SonicWALL: https://www.sonicwall.com/us/en/support/2213.html?fuzeurl=https://www.fuzeqna.com/sonicwallkb/ext/kbdetail.asp?kbid=5952

You should be able to determine connectivity & setup through the test page in the last step.

Let me know how it goes!
0
crcsupportAuthor Commented:
Dam it was antivirus. I disabled avast temporarily, it came up. And also it looks like it takes 1 or 2 minutes to be effective after turning off antivirus.
0
David AtkinTechnical DirectorCommented:
Glad you got it sorted (Y)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.