• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1814
  • Last Modified:

Event Id 1022 on Exchange 2007

Windows 2003 R2 Enterprise 64 Bit SP2

Exchange 2007 Enterprise 64 Bit SP3

Started getting this error

Type :		Warning
Date :		9/14/2013
Time :		6:01:08 PM
Event :		1022
Source :		MSExchangeTransport
Category :	SmtpReceive
User :		N/A
Computer :	SERV005
The description for Event ID ( 1022 ) in Source ( MSExchangeTransport ) could not be found. It contains the following insertion string(s): .
MYPORT1025 Port 1025

I found this

Set-TransportConfig cmdlet.

What would I put on this cmdlet?
Thomas Grassi
Thomas Grassi
  • 6
  • 3
  • 2
1 Solution
Shreedhar EtteCommented:
Please use below command however repalce ipadress with you hub trasport server ip address.
Set-TransportConfig -InternalSMTPServers @{Add="","}
Thomas GrassiSystems AdministratorAuthor Commented:
Thanks for the quick responce

Is that the ip address of my email server?

I only have one server with two nics

The Exchange server use port 25 on  and port 1025 on

Which should I use

And Is there a way to check what is currently set?
Shreedhar EtteCommented:
To Check Current Settings execute below command:
Get-TransportConfig | fl
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Thomas GrassiSystems AdministratorAuthor Commented:


When I enter this

Set-TransportConfig -InternalSMTPServers @{Add="","}

It presents >>   prompt
Looking for more input
Am I missing another "

If I run this
Set-TransportConfig -InternalSMTPServers @{Add="",""}  or

Set-TransportConfig -InternalSMTPServers @{Add="}

Set-TransportConfig -InternalSMTPServers @{Add="",""}

I get this

Set-TransportConfig : Cannot bind parameter 'InternalSMTPServers'. Cannot conve
rt the "System.Collections.Hashtable" value of type "System.Collections.Hashtab
le" to type "Microsoft.Exchange.Data.IPRange".
At line:1 char:41
+ set-transportconfig -internalsmtpservers <<<<  @{add=""."192.168
    + CategoryInfo          : InvalidArgument: (:) [Set-TransportConfig], Para
    + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.Exchang

What am I missing


Thanks for the links but they are for exchange 2013 not sure if the same
nashim khanExchange AdministratorCommented:

This parameter specifies a list of internal Simple Mail Transfer Protocol (SMTP) server IP addresses or IP address ranges that should be ignored by Sender ID and connection filtering.


well that is sure to cause a problem.
you can restore the defaults by running ReinstallDefaultTransportAgents.ps1 from exchange management shell assuming the defaults will work ok for you.

Nashim Khan
Thomas GrassiSystems AdministratorAuthor Commented:
I would like to know why my
Set-TransportConfig -InternalSMTPServers @{Add="","}

did  not work
Thomas GrassiSystems AdministratorAuthor Commented:

What will the reinstall change?

What should I run to see what is currently defined

Then I can run the install to see if that works
Shreedhar EtteCommented:
Please execute this:
Set-TransportConfig -InternalSMTPServers 192.168.1,26
Thomas GrassiSystems AdministratorAuthor Commented:

I am puzzled here now. I have not seen that error message in several days.

My question now is do I need to issue the command?
and do I need to issue it for both ip addresses?
My Exchange server has for SMTP Port 25 and for SMTP Port 1025

The error message was always about SMTP Port 1025

I ran this
[PS] C:\>get-transportconfig | fl

ClearCategories                  : True
ConvertDisclaimerWrapperToEml    : False
DSNConversionMode                : UseExchangeDSNs
GenerateCopyOfDSNFor             : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers              : {}
JournalingReportNdrTo            : <>
LegacyJournalingMigrationEnabled : False
MaxDumpsterSizePerStorageGroup   : 18MB
MaxDumpsterTime                  : 7.00:00:00
MaxReceiveSize                   : unlimited
MaxRecipientEnvelopeLimit        : 5000
MaxSendSize                      : unlimited
TLSReceiveDomainSecureList       : {}
TLSSendDomainSecureList          : {}
VerifySecureSubmitEnabled        : False
VoicemailJournalingEnabled       : True
HeaderPromotionModeSetting       : NoCreate
WritingBrandingInDSNEnabled      : True
Xexch50Enabled                   : True

Your command syntax of Set-TransportConfig -InternalSMTPServers
will add the one ip address can I run it again with Set-TransportConfig -InternalSMTPServers 192.168.1,27 or will that overlay the current entries?

How can I add both?

Do I need both?

Thomas GrassiSystems AdministratorAuthor Commented:
I ran it now the get-transportconfig |fl shows correct information

set-transportconfig -internalsmtpservers,

For both nics connected to this server
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now