USB hard drives inactive problems

Hello Experts,

I am having an issue with a couple of removable hard drives on a server of mine.  I am running Windows Server 2008 standard 32bit and am using software called Paragon Hard Disk Manager to perform daily backups.  I have two identical Western Digital Black 2TB hard drives in external USB enclosures.  Every morning when I come into work and check on the overnight backup the USB drive that was being used is no longer marked as active in the OS nor is assigned a drive letter.  the backups run and are successful but I am having to go in every day and re-activate the hard disk and assign a drive letter so I can use it the next night.  what am I missing here?  This is becoming a major issue because I have different employees rotate doing the backups each day and Its not feasible to have them perform these steps.  Does anyone know what may be causing this or how I can correct it?
zraptorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gary CaseRetiredCommented:
Check your power settings and/or spindown settings.   If the system is going to sleep and turning off USB, then if the drives were spun down when that happened they likely are not detected when the system "wakes up".

If that's not it, is there a possibility of a drive letter conflict?   i.e. do you have both of these drives set to assume the same drive letter?
0
noxchoGlobal Support CoordinatorCommented:
These hard drives are not being removed, right? And the machine is not being restarted - right?
If right then the drives are simply getting into sleep mode.
Check in registry if NoAutomount has been enabled. This could cause such issue as well.
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\mountmgr
In the right pane - NoAutoMount must have value 0. If not then set it and restart the machine. Since the the drives must get the drive letter as soon as they wake up.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zraptorAuthor Commented:
I have checked the power settings and the machine is not set to go to sleep or enter standby mode.  

Both drives are removed daily and taken home so that one drive is receiving the backup and one drive is off the premises to ensure that we always have a good backup off-site.
0
zraptorAuthor Commented:
I do have them both set to use the same drive letter but they are never plugged in at the same time together.
0
Gary CaseRetiredCommented:
It's likely this is an issue with the specific bridge devices you're using.    I'd try a different USB bridge device (i.e. a different enclosure).
0
zraptorAuthor Commented:
okay, I will give that a try and let you know, thank you!

I had been using them in these enclosures before without much of an issue but I did just upgrade from Seagate 1TB drives to these Western Digital 2TB drives, could that have anything to do with it?
0
zraptorAuthor Commented:
I must say, it didnt seem to start happening until I began using this Paragon hard disk manager software to perform backups but I dont see how the software could possibly be causing that or why it would?
0
Gary CaseRetiredCommented:
Certainly the different drives could be interacting with the USB bridge in the enclosures;  but it's also true the Paragon software could be doing something (perhaps spinning down the drives when the backup completes) that may also be contributing to the issue.

I agree the software seems an unlikely culprit; but you may want to disable it for a night and see if the drive still "disappears" overnight.     Or, alternatively, switch one of the units back to the 1TB Seagate drive and see if it has the same issue now.
0
noxchoGlobal Support CoordinatorCommented:
Check the registry key. Is it set to automount disabled?
0
zraptorAuthor Commented:
so far, mountmgr in the registry seems to be working!  thank you all!!!
0
noxchoGlobal Support CoordinatorCommented:
Always welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.