• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 438
  • Last Modified:

Exchange Server Dual Nic Issue

Hi Guys,

We recently added a 2nd NIC to our Exchange server which is an AD and DNS server. The 2nd NIC is being used for a iSCSI connection to a storage array.

For some reason we are running into issues with DNS registering the iSCSI IP Address into DNS constantly even when we manually delete it. We have so far followed the following steps,

- Disabled DNS update registration
- Unchecked "Register this connection" under IP properties, Advanced settings,
"DNS" tab

Is it not possible to have a iSCSI connection on the Exchange server that is running the DNS role?

Any help would be great.

Kind Regards,

  • 2
1 Solution
Will SzymkowskiSenior Solution ArchitectCommented:
Ran into this issue a little while ago. If your server is running DNS and you have duel NICS you need to make sure that your DNS manager is Only listening on the production NIC.

Do the following...
- open DNS Manager
- Right click on the Server Name (not the zones)
- Click on the Interfaces Tab
- You will see "Listen On" by default is it "All IP Addresses"
- Change this setting to only the Produciton IP (uncheck iSCSI IP)
- Apply the changes

By default it will listen on both NICS. I would also check the NIC binding order as well. Go into network connections and press ALT key, click the advance menu, binding move the iSCSI Nic to the bottom. Doing those 2 things should resolve your issue.


SEUPBAuthor Commented:
Hi Will,

Thanks for the comment, we should of said that we did those steps also but it is still appearing in the DNS zone.  The binding order was wrong before but prior to this post - last week we did change the binding order so now our primary nic for the LAN Address is at the top of the binding order with the iSCSI dedicated nic 2nd in the order.

We have also manually changed the metric value against each nic setting the primary nic metric at a value of 2 and secondary nic at a considerably higher value.

We also unchecked the enable round robin option against the iSCSI nic within advanced properties in DNS.
Will SzymkowskiSenior Solution ArchitectCommented:
Weird, as we had the exact same issue and it was due to the listen on setting as mentioned. I would also check the logs as well for DNS to see what might be causing the Nic to register in DNS.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now