Firefox customized from network share and ssl certificates untrusted connection

Hello,
one of the suppliers has provided a custom FireFox 15.0 package for running in multiple istances and loading from a win2008 network share.

Now the issue is that when I load FF connecting to a website that has a SSL certificate not recognized, every time ask to me to add to the expection.

End users are complaining about.

Adding permament to exception saves only to local workstations and per user; if the user moves to another workstations, it ask again to add this exception.

Working on mozilla.cfg and user.js preference file (the package is customized for use these config files), I didn't solve.

What I need is to having the SSL certificate imported on FF package as trusted connection and never will ask to add to exception.

Is there a way to fix it ?

Thank you
LVL 2
pablito70Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
I don't think so.  Firefox stores it's own certificate info in each users profile.  Running from the network share isn't going to fix that problem unless you can find a way to tell Firefox to look on the server for the certificates.
0
pablito70Author Commented:
Hello,
yes, first time runs FF it creates a folder Mozilla in local user profile.
What I'm trying to do is to copy the cert8.db and related files to FF folder on the network share and configuring FF to check SSL in its own dir instead of local user profile dir.
But which settings need to be changed on mozilla.cfg and/or pref.js (or similar)?
0
Dave BaldwinFixer of ProblemsCommented:
I have no idea, I have never run anything from the server like that.
0
msifoxCommented:
The certificate file must now be in a different directory. If you have a cert file in defaults/profile, it must now be in browser/defaults/profile. Same with several other files as well. Much has been moved into browser.
0
msifoxCommented:
And if you use mozilla.cfg, then the js file that declares that Firefox should read this autoconfig file must be in defaults/pref or browser/defaults/preferencfes, not in defaults/preferences.

See also:
http://mike.kaply.com/2013/05/13/more-major-changes-coming-in-firefox-21/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.