Server 2012 Remote Desktop Licence Issues

Hi all,

I have a bit of a urgent issue with my server 2012 install, but first the set up...

So we have 2 servers...1 SBS 2011 and 1 server 2012 that is being used as a Terminal Server.

When a user tries to log onto the server over RDP they get the message :
The remote session was disconnected because there are no Remote Desktop License Servers available to provide a license. please contact the server administrator.

I know this is happening because they are out of the grace period, but I though I had everything set up correctly for licensing...obviously not.

Here is what I have checked so far....

Remote Desktop Licensing Manager :
The server 2012 is listed in there as activated and with 5 licences not handed out
The license server is a member of the terminal server license servers group in AD
The license server is registered a s a service connection point (SCP)

RD Licensing Diagnoser
RD licensing did not identify any licensing problems for the remote desktop Session Host Server

Server Manager > Remote Desktop Services > Overview > RD Licensing >
The server 2012(itself) is listed in here as a licensing server

Ive rebooted the server, but users are still getting the message.

I could really do with some help on this asap. Thank you very much for any support you can give.
SimonBrook99Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony JLead Technical ArchitectCommented:
The only thing that springs to mind at the moment - you don't have a group policy on the SBS server specifying an RD license server (itself) do you?

On the client - is there an event logged?

Edit: This policy:

Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing
Use the specified RD license servers = server IP or FQDN
Set the Remote Desktop licensing mode = Per your license type
0
SimonBrook99Author Commented:
Would that have had to be specified in Group Policy? If I would have to manually specify it then no thats not been done.
0
Tony JLead Technical ArchitectCommented:
Sorry - I was just editing my response to say which bit of group policy to check.

Suspect the SBS server may have a policy
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Tony JLead Technical ArchitectCommented:
So to expand on that - from one of the affected clients if you run a gpresult and look for a policy.
0
SimonBrook99Author Commented:
Sorry do you mean check on the domain controller for this policy? No Pc can RDP onto the Terminal server, inside or outside of the local network.
0
Tony JLead Technical ArchitectCommented:
Sorry - I might not have made that clear. Half thinking/half typing!

If you don't have a large number of policies applying you could browse them on the DC.

But it might be quicker to run a GPRESULT from a client workstation and the 2012 server just to determine if there's one applying.
0
SimonBrook99Author Commented:
Right, so I checked the Group Policy and there is nothing set regarding RD Licensing. I have however set it now to point to the terminal server(this is where the licencing is). I am just in the middle of removing all the RD server roles and the going to try and re install them(someone else suggested trying this) and ill let you know what happens
0
SimonBrook99Author Commented:
I uninstalled the remote desktop services and reinstalled them with single server option.
The remote licensing is up and working and say the licenses are installed. Everything is the same as my first post, so everything appears to my eyes to be correct but I am still getting the error.

I am truly at a loss, and the annoying thing is its gonna be a tick box somewhere....

Help please.
0
Tony JLead Technical ArchitectCommented:
When you say the licenses are on the terminal server, you mean the 2012 server, yes?

Any events logged on the clients or server?
0
SimonBrook99Author Commented:
Yeah on licensing is on the terminal server.

There are no entries in the clients event viewer for this.
On the terminal server is the entry......

Event ID 1130
The remote Desktop Session Host server does not have a Remote Desktop License Server specified. To Specify a license server for the remote desktop session host server, use the remote desktop session host configuration tool.
0
Tony JLead Technical ArchitectCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SimonBrook99Author Commented:
Ok...this is interesting....
I ran the powershell command get -RDLicenseconfiguration and the message comes back :
A remote Desktop Services Deployment does not exisit on server.x.local.

But why does everything appear to be fine in the gui then???

Andy
0
Tony JLead Technical ArchitectCommented:
So sounds like the GUI is misreporting.

Try running the set--RDLicenseconfiguration PS command
0
SimonBrook99Author Commented:
I have deleted the current collection and tried creating a new one, but when creating a new one is complete with the error :
Unable to configure to RD Session Host. Invalid Operation.
0
Tony JLead Technical ArchitectCommented:
Oh I saw that with a Direct Access project I was doing. Had to uninstall the bloody role to get it back. Could try a reboot but suspect it may not help.
0
SimonBrook99Author Commented:
...the plot thickens...lol...

Ok..So i have tried setting the License mode using Powershell and im getting the error A Remote Desktop Services Deployment does not exist on server

Seems like everything is revolving around this issue, so this is what I am going to peruse first.

So please can anyone suggest ways to fix this first?
0
SimonBrook99Author Commented:
Right, if I run power shell as administrator with the following command :

Start-Process powershell -Verb runAs

Then when I run Get-RDLConfiguration it reports back
Mode PerUser
Licencse server
servername, servername.domain.local
0
Tony JLead Technical ArchitectCommented:
Ah yes...Powershell needs to be run under admin priviliges.

Did you explore the other options in the link I sent?

Sounds like a bug on the face of things.
0
SimonBrook99Author Commented:
Yeah its starting to doesnt it.....
I am stuck at the other options as I am unable to create a NewCollections without the error Unable to configure the RD SessionHost, operation invalid.
CategoryInfo : ObjectNotFound : (:) [Add-RDSHServer], RDManagementException
0
SimonBrook99Author Commented:
Problem Solved, it was the registry key entry for the grace period that is a known bug.
Deleted the Reg key, rebooted and boom, job done.

Unreal.

Ironically now I know what it was thanks to your post it seems many people have had the same issue.

Thank you for your help, with this.
0
Tony JLead Technical ArchitectCommented:
But in that article - he mentions that despite deleting it, changing permissions etc it still reports being in the grace period so you might want to monitor that. :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.