DHCP Stopping

Hi All

We have recently installed a new SBS 2011 and we have an issue with the DHCP on the server, for some reason the service keeps stopping with the error - The DHCP/BINL service has encountered another server on this network with IP Address, 1.0.254.169, belonging to the domain: .

 - I have disabled the DHCP on the router
 - no other device on the network has DHCP enabled
 - I have reinstalled the DHCP service and created a new scope (as well as disabling the IPV6 when it asks on install)
 - I have also disabled RRAS and still the service stops.

Any ideas?
R
ryank85Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
So what can you tell us about this device with IP 1.0.254.169 ?? Can you ping this device ? If so, trace and track it (use "arp -a" to check the mac address, maybe you can find it faster (because sometimes you can identify it easily as for instance Cisco device, or Realtek NIC)
Could it even be a second NIC in the server, if so disable this NIC, as the IP number is not correctly setup anyway ?
0
ryank85Author Commented:
Hi

that ip address doesn't appear to be on the network, I am using ip range 192.168.5.x - I have tried to ping and as thought I cannot see it.

I have a 2nd NIC and this is disabled.

I did see on one forum that it could be your ISP, can that be right?
0
KimputerCommented:
Can you check if you have any VPN or remote login software installed either on the server or clients (as in Logmein/Hamachi?)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

ryank85Author Commented:
Hamachi! Yes a few laptop's do but they don't need this any longer.

Could that be it :-)
0
Thomas GrassiSystems AdministratorCommented:
Do you have any VOIP devices? They can cause this type of issue


 run wire shark to check the network
0
ryank85Author Commented:
We have removed Hamachi and still we have the problem.

There are no voip devices on the network.

I will run wireshark. Thanks
0
Sushil SonawaneCommented:
Make sure on your network two dhcp server not running.
0
KimputerCommented:
It can't be a coincident I asked you about Hamachi, and you actually found it installed. Therefore my suspicion is that you forgot one workstation or you didn't reboot everything yet.
0
nashim khanExchange AdministratorCommented:
Hi ,

Please run the below command to get rid from the subject issue.

Netsh delete DHCP servername  1.0.254.169

delete server dhcpsrv1.example.microsoft.com  1.0.254.169


See the below link it will guide you properly.
http://technet.microsoft.com/en-us/library/cc787375(v=ws.10).aspx


Regards
Nashim Khan
0
ryank85Author Commented:
I have checked the Server and only 192.168.5.2 is authorized as a DHCP Server

I have tried this command and it cannot find anything - Netsh delete DHCP servername  1.0.254.169

I am due onsite tomorrow so I am going to check each PC for the hidden Hamachi software.  I have used this in the past though with other clients and this hasn't caused any issues.

I will keep you updated.

R
0
nashim khanExchange AdministratorCommented:
Hi Ryank85.

Please perform the command as per the given in below article.
http://support.microsoft.com/kb/303351

Or you need to disable the DHCP from registry, see the link below.

http://windowsitpro.com/networking/disabling-dhcp-through-registry


Regard's
Nashim Khan
0
ryank85Author Commented:
Hi Nashim

I have tried this and my server 192.168.5.2 is authorised which is correct, when I start the service now I get this error in event viewer

When I run the delete command it doesn't find that IP address.

The DHCP/BINL service on the local machine encountered a network error. The error was: 0x       2.

It doesn't show that IP address as it did before.

R
0
nashim khanExchange AdministratorCommented:
Ryan,


Please follow the below article and revert if issue not get fixed now.

http://us.generation-nt.com/answer/sbs-2008-dhcpserver-error-1050-help-197531111.html

Regards
Nashim Khan
0
ryank85Author Commented:
Hi Nashim

The DHCP Service doesn't stay on for more than 5 seconds so I cannot access these settings.

R
0
Thomas GrassiSystems AdministratorCommented:
Do you have any other Windows servers on this network?

If DHCP is authorized on this domain and it starts and then fails there is another DHCP server running somewhere on the network.

What errors do you get in the dhcp event log?
0
ryank85Author Commented:
Hi trgrassijr55

Yes this is the only server on the network offering DHCP.

The router DHCP is disabled.

The EV is showing error - The DHCP/BINL service on the local machine encountered a network error. The error was: 0x       2.
1
Thomas GrassiSystems AdministratorCommented:
Ok lets try this

http://technet.microsoft.com/en-us/library/ee941207(v=ws.10).aspx

1. Click Start, type regedit in Start Search, click Yes in User Account Control if prompted, and then press ENTER.
2. In the registry tree, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\DHCPServer\Parameters.
3. Right-click DisableRogueDetection and then click Modify…
4. In Value Data type 0 and then click OK.
0
ryank85Author Commented:
I have seen an article like this - this is going to be my last option

I will know more tomorrow when I get onsite and see what's going on

thanks
R
0
ryank85Author Commented:
Just found this on logmein - http://community.logmeinrescue.com/t5/Hamachi/Gateway-network-issue-Rouge-DHCP-server-sending-DHCPNACK/td-p/62866

this is the same IP address I have seen in the event viewer.

It must be Hamachi that's causing the problem as per the comment left this afternoon.

thanks
R
0
Thomas GrassiSystems AdministratorCommented:
Yes that is a good possibility

The reg change will help you determine that too
0
hecgomrecCommented:
Sorry to get a little late to this one....

If your "real" DHCP server is down, are you getting an IP that's inside the range of the rouge/offender range?  You won't be able to find the offender if you are not in the same network.

I don't know how big the organization is, can it be fragmented to find out the floor, department, building, etc... by leaving only certain switches/routers working to narrow down the search.

Try to see besides the possibility of another HAMACHI/HIMACHI if no one else has another proxy server around like Wingate with DHCP enabled even in the server.
0
ryank85Author Commented:
Hi All

Just to update you, I dialled into the laptops 2 days ago and removed hamachi from all laptops, rebooted the server and all laptops and everything appears to be ok at the moment.

Thanks Kimputer - I will keep an eye on this over the weekend and close this ticket on Monday

thanks again
R
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.