rdweb trust remoteapp

Hi, i have a W2008 R2 with RDWEB, SSO works, but when starting a program from web there is allways a windows with warning to trust this remoteapp. I have tried to upgrade RDP but it dont help.
18.09.jpg
per-wAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jackie ManCommented:
1. Goto C:\Windows\Web\RDWeb\Pages\en-US\ in your W2008 R2

2. Locate the file default.aspx

3. Edit the file with the following:

   Find;
   public bool fUserAdmin = false, fConfigPage = false, bShowPublicCheckBox = false, bPrivateMode = false;
   Change to;
  public bool fUserAdmin = false, fConfigPage = false, bShowPublicCheckBox = false, bPrivateMode = true;

Source: http://social.technet.microsoft.com/Forums/windowsserver/en-US/c7c226c9-542c-40f2-b4e3-7a846fc7848e/rdgateway-rdweb-remoteapp-how-do-you-remove-make-sure-that-you-trust-the-publisher-warning
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
per-wAuthor Commented:
hm, i tried that but nothing happens. BUT if i also set the bShowPublicCheckBox = true then i got a litle box to check that the pc is private on the windows where all application icons is and its a checkbox in the trust window to not show again, but the problem is that then i got error that there isnt any remote gateway server. When setting it to false everything is back to normal with the trust window :-(
0
per-wAuthor Commented:
i did this and then it works, your (jackieman) code + some in login.aspx

removed checked from rdoPblc and inserted checked in rdoPrvt

Now its checked for privat on login window and its cheked for privat in program window and there isnt any trust windows at all :-)
0
per-wAuthor Commented:
Jackieman put me in right direction and now its working.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.