uninstall roles from a exchange server in a cluster failes on public folder replica's

I'm trying to uninstall all existing exchange roles on a server in a exchange cluster.

The roles on this server are:
-Mailbox Role
-Client access fole
-Hub transport

We used this server for testing purposes. We (re)moved all mailboxes. And we want to uninstall the exchange roles now.

When i deselect the roles to uninstall them i recieve this error on the prerequisites page:

"Uninstall cannot continue: Database 'Public Folder Database': The public folder database "server name\storage group\database" contains folder replicas. Before deleting the public folder database remove the folders or remove the replicas to another public folder database."

You can also check the attachment.
error during uninstall
The public folders are constantly used by the users. I can found a lot of articles how to delete the replica's and database while uninstalling exchange from the organisation. That is not what i want to do.

When i connect to the public folder management and check the properties of a public folder i see that there is a replication entry. Do i have to delete those? That will be a hell of job to do on 1000+ public folders.

Any advise would be helpfull.
LVL 3
computicationAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Yes you need to remove the replica, however you can do it using Powershell to do it faster. Use this
http://exchangeserverpro.com/exchange-2010-remove-public-folder-database/
0
computicationAuthor Commented:
Hm,

When i run this script:
Get-MailboxDatabase | ft name,publicfolderdatabase

The to be uninstalled server is not listed

And when i run this script:

Get-PublicFolderDatabase | where {$_.customreferralserverlist -like "*scrambled*"}

then the server isn't listed as well.

Is it necessary to go into adsiedit then?
0
AmitIT ArchitectCommented:
ADSIEDIT is mentioned as last option, if you read the article. So not required, if you are able to move replica with PS script.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

computicationAuthor Commented:
Yes, but the server isn't listed as a replica of our public folders. So i think there is no replica to move.
0
computicationAuthor Commented:
There were a few system public folders wich was preventing the uninstall. Removing those unused ones was the solution.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
computicationAuthor Commented:
solution found by self troubleshooting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.