• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4758
  • Last Modified:

ESXi 5 stuck on restarting management agents


deleted 4 or 5 datastores from two esxi hosts yesterday. went to rescan all and one of the hosts timed out and then showed disconnected in vSphere Client. All VMs on the host are working except one (may be unrelated. I can ping it, but can't RDP. Get an error about not enough resources to login).

Couldn't SSH. Putty kept failing due to network error. Went to console and restarted management agent through GUI. Agent stopped OK, and quickly. It has been stuck on starting management agents for about 30 minutes.

Any help on starting the services without rebooting would be great.

king daddy
king daddy
1 Solution
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if this is iSCSI Datastores this can happen.

I'm afraid restart the Host Server!!!
king daddyAuthor Commented:
aarrgh! I figured as much from past experience, but was remaining hopeful until an expert confirmed. I really need to learn to wait until the weekend to deal with storage stuff. I just wanted to clean up a bit and add some new datastores!

anyway, thanks.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now