Installing kernel resource in CentOS 6

Hello experts,

I have setup CentOS 6.4 minimal version on a server. I am trying then to install a driver called (DAHDI). First when I try to compile the DAHDI using (make all) command, I receive this error:

You do not appear to have the sources for the 2.6.32-358.18.1.el6.i686 kernel installed.

How to solve this? Please I need steps, not long descriptions of the problem as I found in lot of sites.
MuhajreenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slubekCommented:
You don't have kernel-headers packet installed.
If you have active internet connection and properly configured yum sources, do as root:
# yum install kernel-headers

Open in new window

BTW, you can find dahdi drivers in atrpms repository
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MuhajreenAuthor Commented:
Thank you.

kernel-headers is already installed and up to date.

So what's wrong???
0
MuhajreenAuthor Commented:
Ok I have just tried installing kernel-devel and it solved my problem :)

Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.