WSUS Ver 3.2.7600.226 issue with deployment of patches to Some 2008 R2 servers

Issue :
Patches last installed on a few Server 2008 R2 versions in May 2013
On other Servers also Server 2008 R2 patches is being deployed regularly

Setup of WSUS
Automatically approve , Critical and security patches and deploy automatically
on the Windowsupdate.log of one of the servers with an issue

2013-09-19      14:08:46:173       844      1618      PT      WARNING: Cached cookie has expired or new PID is available
2013-09-19      14:08:46:173       844      1618      PT      Initializing simple targeting cookie, clientId = 277598c7-92df-4254-8aa0-e13c0f3b8f7a, target group = Windows-2008, DNS name = wbsav1.workbridge.local
2013-09-19      14:08:46:173       844      1618      PT        Server URL = http://<SERVER>:8530/SimpleAuthWebService/SimpleAuth.asmx
2013-09-19      14:08:53:068       844      1618      Agent        * Found 0 updates and 72 categories in search; evaluated appl. rules of 459 out of 1055 deployed entities
2013-09-19      14:08:53:084       844      1618      Agent      *********
2013-09-19      14:08:53:084       844      1618      Agent      **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2013-09-19      14:08:53:084       844      1618      Agent      *************
2013-09-19      14:08:53:099       844      1ac8      AU      >>##  RESUMED  ## AU: Search for updates [CallId = {846D6C05-4CDA-4EAA-8588-BCB20D0A197F}]
2013-09-19      14:08:53:099       844      1ac8      AU        # 0 updates detected
2013-09-19      14:08:53:099       844      1ac8      AU      #########
2013-09-19      14:08:53:099       844      1ac8      AU      ##  END  ##  AU: Search for updates [CallId = {846D6C05-4CDA-4EAA-8588-BCB20D0A197F}]
2013-09-19      14:08:53:099       844      1ac8      AU      #############
2013-09-19      14:08:53:099       844      1ac8      AU      Successfully wrote event for AU health state:0
2013-09-19      14:08:53:099       844      1ac8      AU      Featured notifications is disabled.
2013-09-19      14:08:53:099       844      1ac8      AU      AU setting next detection timeout to 2013-09-19 05:22:08
2013-09-19      14:08:53:099       844      1ac8      AU      Successfully wrote event for AU health state:0
2013-09-19      14:08:53:099       844      1ac8      AU      Successfully wrote event for AU health state:0
2013-09-19      14:08:58:091       844      1618      Report      REPORT EVENT: {24D537B8-BC80-4EA5-94A2-F94FB8D37A02}      2013-09-19 14:08:53:084+1200      1      147      101      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Software Synchronization      Windows Update Client successfully detected 0 updates.
2013-09-19      14:08:58:091       844      1618      Report      REPORT EVENT: {D08B2BB5-0E65-4091-A164-6ACFFBCD5528}      2013-09-19 14:08:53:084+1200      1      156      101      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Pre-Deployment Check      Reporting client status.
2013-09-19      14:08:58:107       844      1618      Report      CWERReporter finishing event handling. (00000000)
2013-09-19      14:19:35:181       844      1618      Report      Uploading 2 events using cached cookie, reporting URL = httpSERVER>::8530/ReportingWebService/ReportingWebService.asmx
2013-09-19      14:19:35:196       844      1618      Report      Reporter successfully uploaded 2 events.


Only difference between the servers are that the ones with Server 2008 R2 SP1 gets updates , and the others with NO SP1 does not , this is the only difference we can spot at this stage.

Is SP1 the solution or is there a way to get patches deployed till we can do an upgrade of the servers without SP1 , or if there are any other reason?
JakesCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smckeown777Commented:
Your WSUS is possibly running an older version of the WUAgent than the other servers...

See this post for fix - install KB2720211 on the WSUS server to bring it to the latest version...

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_28195463.html
0
JakesCAuthor Commented:
On the "server A" Which is the WSUS server and is win2008 R2 with NO SP, there are no patches deployed
Had a look patch KB2720211, it is installed on server A
On the WUAPI.dll (WUAGENT) version no is 7.6.7600.256

On "Server B"
Server 2008 R2 SP1 on which the patches do get installed,
This server has WUAGENT version 7.6.7600.256 too

Are there any other update after XXX.256 for the Agent ?
0
smckeown777Commented:
Ok, so that's good at least you've the required updates installed...

What do you mean by - 'On the "server A" Which is the WSUS server and is win2008 R2 with NO SP, there are no patches deployed'??

Which patches are not deployed? What does the status in the WSUS console for this server show? What percentage value of applied updates are showed? Normally in the WSUS console you see a percentage(75%, 88%, 99%) - does this server show 99%? Or what does it show?

Also possibly you aren't getting those patches due to the SP issue, realistically to get certain patches to apply you need a SP level - so possibly since the server isn't SP1 level those patches don't apply...but the percentage value will tell us more on this I think
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

JakesCAuthor Commented:
RE: Which is the WSUS server and is win2008 R2 with NO SP, there are no patches deployed'??

If a comparrison is run of how patches are installed between A and B
 > "A" has not had Updates for a few months  and "B" has had patches deployed month by month constantly

Percentage value shows "A" 100% and "B" 100% installed or not applicable

Will check the SP1 install.

additionally: on the WSUS server Server A
ran wsusutil checkhealth ....... result in Event Viewer = Self update is not working

will check that out too
0
JakesCAuthor Commented:
We have installed SP1 on the Servers in question and there seem to be Patch updates deployed now. So conclusion : there might not be that many Patch updates around for pre SP1.

Thanks All
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JakesCAuthor Commented:
Comparing servers that does get patches from the same WSUS server , the difference was SP1 on WIndows server 2008 .
Ran SP1 on all servers in question
Since then , all good
0
smckeown777Commented:
Should my answer http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_28243623.html#a39507446 not be the solution for this question? I said
Also possibly you aren't getting those patches due to the SP issue, realistically to get certain patches to apply you need a SP level - so possibly since the server isn't SP1 level those patches don't apply

I think that should qualify as correct answer...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.