Outgoing email fails after replacing Linksys router

Connection to Internet 1Connection to Internet 2Hi,

 I have SBS2011 with Exchange server and I have been using my Linksys 54G Router with port forwarding for IIS, OWA, HTTP, TS .. etc.  I have decided to replace it with modern D-Link N router and matched port forwarding on the new router.
 All was working fine - RWW, OWA, Terminal Server Access except no one could send email out.
------------------------
Delivery has failed to these recipients or groups: The following organization rejected your message: smtp02.knology.synacor.com.
smtp02.knology.synacor.com #554 Authentication Failed, must login ##
------------------------

Finally I ran "connect to the Internet" on SBS Console and it detected a new router (with the same IP address as Linksys ??) and all emails are going out now.
So all is fine now, but I like to know why emails did not go out until I ran "connect to the Internet" on SBS Console? At the end, there was no change in SBS Server IP address or Router IP address.

Thanks.
LVL 1
sgleeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

piattndCommented:
It sounds to me like the router was expecting some sort of first time authentication or some sort of initialization from the server.  That's very odd behavior though.  I'm guessing you have a static IP set to the local server and you already stated the gateway address didn't change.  The "connect to the internet" action could have performed other steps, like flushing DNS or something else that could have resolved the issue, though I can't tell you for sure what else it could have done.
0
sgleeAuthor Commented:
I am wondering if SBS was looking for something else other than IP address of the router ... like MAC address of the router ??
0
piattndCommented:
Nah, it would look at the IP address you have established as the gateway.
0
sgleeAuthor Commented:
Any other explanations out there?
0
WORKS2011Austin Tech CompanyCommented:
This isn't odd behavior for SBS, SBS loves the wizards and this is common when replacing any hardware device like a router on a SBS device. Making the point that running the wizard is needed when changing out routers on a SBS network. Exactly what is happening I suspect possibly a MAC address change or something like this, while it appears nothing is happening because you see the IP's detected there is obviously something of value (probably security related) that is allowing the new device to work. As well SBS makes every attempt to simplify things. Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.