Citrix published Internet Explorer app error

Have a bit of a strange issue with a published app that is opened via IE.

Just for quick FYI of the network, the Citrix XenApp is running on a 2008R2. The application is web based and is custom. The client has 5 static IP addresses coming into the building with the associated services config properly on a Sonic Wall pointing to the needed servers (Exchange, 2 Citrix servers, web server, etc).

The app will only work if I make the start-up command in Citrix to the local server name instead of the web DNS value - "C:\Program Files (x86)\Internet Explorer\iexplore.exe" http://(local server name)/bba/Framework/appbba.aspx instead of "C:\Program Files (x86)\Internet Explorer\iexplore.exe" http://(DNS value.com)/bba/Framework/appbba.aspx. The issue here is that there are a few parts of the application that does sub-calls when click on a pull-down that errors because it is hard-coded to the true DNS web name.

error screenshot
I have tried mult different things such as make special A records in DNS, etc. Nothing works and this is a problem since all their remote users work from Citrix. Just as an FYI, if you open the app in IE outright the sub-call link works fine. Issue why cant just run from there is that they have to print reports and pull and send info from other areas in the network so I really need it to work from Citrix with the true DNS web name if at all possible.
bcp_cnsllcAsked:
Who is Participating?
 
bcp_cnsllcConnect With a Mentor Author Commented:
You actually brought up the only work-around that I was able to figure out.

If I open IE in Citrix and go to the website it prompts me for 1 extra authentication page but loads correctly after clicking  past that extra with that option avail and working that wont as a published app.

If I cant make it work I plan to make a published IE instance with the outside DNS sitename as the default homepage (in Control Panel>Internet Options) and then just publish another IE instance with say MSN, Google, company website (whatever), as it's opening homepage to override the settings I made in Control Panel>Internet Options. But this presents other issues especially for the users that work exclusively from the Desktop where this option will not work unless I create cheating shortcuts to open to another page for IE or have them use Mozilla, etc.

I think part of the issue is that the app (believe but cant confirm) is hard-coded with the web DNS name and since I cant get it to run in Citrix with the outside address but rather the internal name is part of the problem (see above orig post).

But what bothers me with that thought is if it goes to the site and get it running with the internal name, then internal linking within the website should then take over and make it open the required page - shouldn't it??
0
 
BlueComputeCommented:
What does NSLOOKUP give you on the XA server for your public DNS name?  Have you tried hacking the hosts file for testing?
0
 
bcp_cnsllcAuthor Commented:
I will take a look at the lookup a little later today but screwed around with both the hosts and making new physical records in DNS didn't do anything.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Ayman BakrConnect With a Mentor Senior ConsultantCommented:
Have u tried launching IE from Citrix then asking your client to type in the DNS address of the app? Does this work? What about the local address; does it reproduce the error?
0
 
Ayman BakrSenior ConsultantCommented:
One of my questions were not answered: what happens if you launch IE and type local address instead of the DNS, does the app work fine?

I agree with your reasoning and would expect the internal intricacies of the app should handle all communications regardless of the address typed in. For this you need to consult with the app developers to see if this was hard-coded.
0
 
bcp_cnsllcAuthor Commented:
Same exact error whether I go with the internal name or internal IP address.

I have asked them regarding if this was a hardcoded page or a straight imbedded link and I have yet to get an answer.
0
 
bcp_cnsllcAuthor Commented:
thank you - dont know why it put it into Exchange except that I had an outstanding regarding Exchange at the time.
0
 
Ayman BakrSenior ConsultantCommented:
Let's see their reply! Meanwhile if you find any event log relating to this then please post it.
0
 
bcp_cnsllcAuthor Commented:
There has been no change in this and looks like people pretty much have given up.

The only work around / solution I could find was to what Mutawadi also said (missed typing that in the original post - sorry about that) which was setup IE in Citrix>Desktop to open to the external webpage address as it's home page. Then I have a published IE open to the home page (which is the app webpage) and it does go there and appears to work with the only issue of it asking for one extra authentication page. Then to give them a published version of IE that they can use to browse with, I then publish another IE with the command line to open say MSN or something like that.

Sucks but I cant find another way around this and the vendor is like "well it works if go through IE outright so has to be a Citrix issue." The solution appears to work for now but who knows what else will find and is why the solution is average at best because while it works for now is nothing more than a jury-rig. I will continue to bang on this and if get something better or at least an answer as to why (cant get the vendor to explain why the web wont take over the routing once in it or answer if I am correct in my assumption that that component is hard-coded) I will post a follow-up if allowed to.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.