• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 16787
  • Last Modified:

Excel 2010, Insert Embedded Object - Error "Cannot Insert Object" for Adobe PDF's

We have just upgraded our software to Office Pro 2010.

In Excel 2010 we try to Insert an Object, on 'Create from File' tab and then browse and select a PDF file.

The error message "Cannot Insert Object" appears.   It only happens on PDF's.  Tested with jpeg, Word and any other type of file works fine.

It leads me to believe there is something wrong with Adobe Reader.
We have the latest version to date  = Adobe Reader 11.0.04

There are many help forums mentioning the "Protection Mode at Start Up".  This has been disabled but still have the same error message in Excel.

Please help!
Thanks
MChallinor
0
Mchallinor
Asked:
Mchallinor
1 Solution
 
Harry LeeCommented:
Mchallinor,

I use Office Pro 2010, and I have no problem inserting PDF object onto Excel 2010 Worksheet.

Is "Cannot Insert Object." the only thing it shows? Is there more information from the error message?

There are a few things that could have cause the problem.

1) Did you try updating Adobe Acrobat Reader to the latest version, I saw somewhere that there is a bug in Acrobat Reader X that cause the problem even when you have Protection Mode disabled.

2) PDF file format error. Where did you get the PDF file from ? Did you create it yourself? What software did you create it with? There are many software, nowadays, that create PDF files but I found that not all are the same. Some of those software create PDFs with error in the file structure. Which had cause me some trouble in the past. As long as the file is created by a proper software, such as Adobe Acrobat, there is no problem at all.

3) I'm using Acrobat 9 Standard, and I don't have Adobe Acrobat Reader installed at all. I'm wondering if that makes a difference. I doubt it though. Since MS Office 2010 can handle PDF on it's own, the Reader issue should not affect you.
You can choose to uninstall Acrobat Reader completely, and redownload it from Adobe and reinstall it again if you want to give it a try.

4) MS Office is damaged. If the above 3 points did not solve your problem, there is no harm to try repair MS Office to see if that's the cupid. Go to Control Panel -> Programs and Features. Find MS Office and click change. In the popup window, choose Repair and Continue.

Hope this help you.
0
 
MchallinorAuthor Commented:
There is a work around that solves this issue.
Goto INSERT/   Object / Create New , then select the PDF you wish to insert.
It is effectively the same as the Create from File tab.
 Problem solved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now