Checkpoint 680 VPN works on Mac and XP not in 7

I have a checkpoint 680 with the L2TP windows VPN setup. I was able to connect a mac in about 5 minutes. XP took 2 days but I was finally able to connect. Windows 7 will connect but when you go to the status window for the vpn it says it is not connected to the network. I have triple checked that all the settings are the same between the xp and windows 7 machine and one of our vendors was able to duplicate this behavior. They can connect with xp but not 7. I have setup the connection via Checkpoint's instructions as follows:

1. In options deselect include windows logon domain
2. In ppp settings only lcp connections should be checked
3. Under security L2TP should be selected with the preshared secret in the advanced settings
4. Under Data Encryption select Optional encryption
5. Select allow these protocols and have only unencrypted password selected
6. When connecting for the username type the usename only. Don’t include the Domain. Type your account password and you should be in.
wablo666Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joelsplaceCommented:
I would make sure you have the latest NIC drivers.  7 has had a lot of strange issues that randomly show up and NIC manufacturers have been releasing tons of updates ever since 7 came out attempting to fix various strange problems.
0
wablo666Author Commented:
I'll try that but it seems weird it would be reproducible on several different systems.
0
joelsplaceCommented:
I didn't see where you mentioned more than 2 Win 7 systems.  The driver may not help but is it possible that they all have the same NICs?  Realtek is very popular and they have released a ton of updates.  If it's just a problem with Win 7 in general Checkpoint should know about it and be able to tell you what to do.
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

wablo666Author Commented:
Trying to not buy a service contract with checkpoint if I don't have to. I updated the nic which is an Intel 82579LM. I still get this in the vpn status:VPN status
0
joelsplaceCommented:
It looks like the VPN is up but no traffic is being routed through it.  I would do an ipconfig /all and see if the VPN is getting a proper IP address and then check route print to see if the route is set for it.
0
joelsplaceCommented:
You can do a route print on the XP box before the VPN is connected and after to see what is supposed to happen and then do the same on the 7 box and compare.
0
joelsplaceCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wablo666Author Commented:
This works. I wanted to get this to work with windows built in software because I hate when things don't work but this is a good and viable solution. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.