Quickbooks running on Linux Server via SAMBA

I have  a client that I installed a linux server years back, they are running a copy of quickbooks PRO 2012 on their windows systems and the quickbooks data files are located on the server.

When they had windows XP they were able to switch the files back and forth from single user mode to multi user mode in quickbooks. I don't know why they did it but they would switch back and forth for some odd reason.

Once the windows boxes were upgraded to Windows 7 it give and error of H202.
SO now they cannot switch back and forth. I tried the following.
turned off firewall, on windows box
turned off iptables on the server
turned off selinux on the server
turned of antivirus on the windows box
check permissions of the folder and made sure it was granted full permissions off the windows box

but for some reason non of this is working. If I go in with an XP laptop it works so this is telling me this is a windows issue. What can I try?
georgopanosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
The issue with single mode and multimode deals with a special quickbooks monitoring service that controls the access.

The only way to achieve this with the data being stored on a Linux box is to serve up the share via iscsi to a system that will see the resource as a "regular drive" and where the quickbook monitor can monitor this drive letter and arbitrate access.
0
georgopanosAuthor Commented:
I am not following if I use an XP machine it works fine but with Windows 7 the issue occurs.
0
arnoldCommented:
Does the windows 7 have the quickbooks monitoring service running?
Quickbock monitoring is the access arbitrator that must run.  Look at the ND file within the directory where the company file is and you will see that it references the system and a port that has to be contacted. I think it refers to the host/port that activated multi-user.
the tool can not monitor networked drives. The port is randomly picked
You would always use the XP_mode within windows 7 to install quickbooks.

IMHO, quickbooks in multi-user mode requires that the quickbook monitor service run on the system where the company files are on a "local" hard drive (internal hard drive, FC harddrive, iscsi harddrive).
0
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

georgopanosAuthor Commented:
Sorry about the delay getting back to this question, if the service is not running can I install it?
0
arnoldCommented:
The service only runs on a windows system and it will not monitor mapped network drives. The service does not see them.
0
arnoldCommented:
To correct my prior comment, have a look at http://support.quickbooks.intuit.com/support/articles/HOW12295
But it might apply to enterprise versions of quickbooks only.

They have the monitoring service that runs on Linux.
0
georgopanosAuthor Commented:
Yes you are correct that applies to the enterprise version.


I have been trying to get into the office to correct the problem, they have been to busy to get into.
0
arnoldCommented:
The difficulty is that it is rare that the service runs on local workstations and the additional hindrance deals with a user on workstation A will have the .nd file referencing workstation A port preventing anyone else from access when workstation A is off.

An admin would need to modify .nd, but the next access might  repeat the process.

I am contemplating/working on a similar setup with the share on  a Linux system.

In  a non-enterprise version, using an iscsi with a windows server might be the only way for multi-user mode,  if the users can manage not to access the same file, that would be the solution.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
georgopanosAuthor Commented:
I chose the Multi User mode and the error poped up and there was a choice at the bottom was "alternate setup". This worked I don't understand why but it is allowing the system to switch back and forth between sing and multi user mode while the files are stored on a linux server. Any idea?
0
georgopanosAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for georgopanos's comment #a39586760
Assisted answer: 500 points for arnold's comment #a39569930

for the following reason:

So the exact way of getting this to work is selecting alternate setup from the error message and for some reason it works I am not sure what it is.
0
georgopanosAuthor Commented:
**********************
IMPORTANT PART OF IT!!!!!!!

By selecting alternate setup from the error box it allowed the switching of multi user to single user back and forth. So that is what needs to be done from what I can tell. Now I am not sure if from another machine you can change back and forth. But data lives on linux server and multiple people can open the same file.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.