Windows 7 PRO Workgroup Not Showing Shares to all Users

I have inherited a client that has 13 computers connected as a Workgroup all running Windows 7 Pro.  I would have advised them long ago to get a server, but not in the budget for them right now....  The problem seems to lie with the Windows 7 Pro PC that is acting as the host (server) for all of their shares.  One person will upload a new pictures to the server but only he can see the uploaded files for 1 to several days.  Even if I go to the server itself, I cannot see what he has uploaded.  However, from his desktop, the files are located at //server/shares/pictures....  After a couple of days, the files "magically" appear for everyone else.  I have already tried the following registry edits that I gleaned from other posts...

HKLM\System\CurrentControlSet\Control\Session Manager\Memory Management----changing LargeSystemCache to 1

HKLM\System\CurrentControlSet\services\LanmanServer\Parameters----Changing size to 3

Any suggestions would be greatly appreciated.  This is a small town newspaper and making deadlines having to sneaker net pictures and files is getting old really fast.
TechnologyDoctorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dswattCommented:
Try disabling the firewall service on the Windows 7 machines, not just turn off but disable the service so that it doesn't start
0
TechnologyDoctorAuthor Commented:
Won't that leave them extremely vulnerable?
0
dswattCommented:
In short yes, however its a great troubleshooting step and narrows down what may or may not be broken.
if the pictures appear right away, you have to alter the firewall rules to allow the file sharing for all the computers, this will test whether you have the network configured correctly. In windows 7 the firewall disables most things by default, when you add file sharing it opens default values they may or may not be the correct values, quick easy test is to disable the service, and then upload new files, and see if they appear right away.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

TechnologyDoctorAuthor Commented:
Thanks, I'll drop by and try on Monday.
0
TechnologyDoctorAuthor Commented:
Sorry for the delay in follow up, but the firewall fix didn't change anything.  However, I stumbled upon the following fix...

Registry Edit:
HKLM\System\CurrentControlSet\Control\Lsa|LMCompatibilityLevel  -- Change Value to 1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeeTutorretiredCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.