When I ping another system by host name on my network, I no longer get a 192.168.x.x response, but rather an IP like 69.16.x.x.

As a result, i get "Request timed out". This is when I try to ping by hostname from one computer to another. They are both joined to the domain. I even tried taking both off the domain, and just adding them to same workgroup, but to no avail. I can ping by IP, but why when I ping by hostname, I get the weird 69.16.x.x address. I want to be able to resolve by hostname.
jaedenoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan CraciunIT ConsultantCommented:
What is the result of nbtstat -c ?

Also, check your hosts file (System32\drivers\etc\hosts)
0
Sajid Shaik MSr. System AdminCommented:
1) disable firewall on both PC's windows firewall as well as Antivirus Firewall if any...

2) Lan properties disable(uncheck) ipv6  or use following fix
http://support.microsoft.com/kb/929852

3) Check IP address gateway or subnet mask

4) this could be DNS service issue... start-Run- services.msc and stratr DNS client service.

5) log on to c:\windows\System32\Drivers\Etc\hosts   check is there any unncecessary entries related to the same pc or ip there ?

at last check event log.
0
Dave BaldwinFixer of ProblemsCommented:
Are you at the University of Massachusetts?  IP addresses 69.16.0.0 - 69.16.127.255 belong to them.
0
Darr247Commented:
Or do you mean 169.254.xxx.xxx, which is the Automatic Private IP Addressing (APIPA) range?
0
Giovanni HewardCommented:
Check your IPv4 DNS server settings; to resolve locally you need to use local DNS servers as opposed to public.  Your local DNS server(s) should use forwarders to resolve names outside of their zones.  

You can test this manually by modifying %windir%\system32\drivers\etc\hosts on both machines, using both the FQDN name and the host name.

192.168.1.10     host host.domain.local

Your client should also be configured to automatically append the proper DNS suffix (i.e. your local domain); so when you ping host suffix .domain.local is automatically appended.

 Use proper domain.local suffix here
You can apply this automatically to all domain hosts via GPO, DHCP Scope Options, and Registry modification scripts.

i.e.

reg add HKLM\system\currentcontrolset\services\tcpip\parameters /v "SearchList" /d "domain.local,domain.com" /f

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.