SBS 2008 add DNS suffix to VPN clients

Dear experts,

I have SBS2008 box with VPN configured by the SBS wizard. If some non domain computer connects to VPN, he cannot ping hostname. IP and FQDN works fine.

I do not want to use hosts file, WINS. I know there is a simple solution on a server side, but I cannot find it


Regards,
Jarda
LVL 7
Jaroslav LatalMSPAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lruiz52Commented:
You have to set your dhcp server to hand out dhcp option 115 for single searc DNs suffix or option 119 for multiple search DNs suffixes. Check link below;

http://technet.microsoft.com/en-us/library/dd572752(v=office.13).aspx
0
Jaroslav LatalMSPAuthor Commented:
Sorry lruiz52,

it seems the link is not for SBS 2008, but communication server 2007 or server 2003.
In my DHCP server option is no 119 at all.

I think I need to configure routing and remote access to assign a DNS suffix, but I cannot find where is it.


Jarda
0
Frosty555Commented:
It is not configured in RRAS. It is configured in one of two places:

1) If your RRAS is configured to use a DHCP Relay Agent and assign IPs to the clients automatically, then look in your DHCP Server settings, under Scope Options, add Option 015 and specify the domain name

2) Otherwise, the the DNS suffix settings of your primary network adapter is passed along (Network Connections->Local Area Connection->Properties->Advanced->DNS tab->DNS Suffix
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Jaroslav LatalMSPAuthor Commented:
Hello Frosty555,
I already have DHCP option 15 configured (FQDN), as well as DNS suffix in advanced properties of nw adapetr.
When some non domain member computer tries to ping hostname, it works. Problem is only through VPN.

Jarda
0
Frosty555Commented:
On your non-domain-member computer, after you are connected to the VPN, what does it show when you do an ipconfig /all?

Does it show your domain name for the "Connection Specific DNS Suffix" option of the PPP adapter VPN connection section?

Also, in RRAS, under YOURSERVER->IPv4->DHCP Relay Agent, have you added your primary network interface to the list?
0
Jaroslav LatalMSPAuthor Commented:
no, after connecting to VPN there is no connection specific DNS suffix on PPP adapter..

I cannot find "Also, in RRAS, under YOURSERVER->IPv4->DHCP Relay Agent, have you added your primary network interface to the list?" but it sounds interesting. Where exactly it should be?


Jarda
0
Jaroslav LatalMSPAuthor Commented:
I needed to add DHCP Relay Agent, right click on the DHCP Relay Agent node in the left pane of the console, click the New Interface and select internal.

Thanks Frosty for your help.


Jarda
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jaroslav LatalMSPAuthor Commented:
My post describes the solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.