Exchange 2010: Outlook Profile Updating Incorrectly after Mailbox Move

We are in the process of moving mailboxes from Exchange 2003 to Exchange 2010.  Clients are Outlook 2010.  After the mailbox is moved and Outlook is launched, some users can't connect to their mailbox.  When trying to recreate the profile Outlook autoconfigures and connects to the Exchange 2010 mailbox server instead of the CAS array.  The workaround is to hard code the CAS array in.  Anyone see this problem before?
LVL 8
bsohn417Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Antonio VargasMicrosoft Senior Cloud ConsultantCommented:
the outlook will connect to the server, or cas array defined on the rpcclientaccessserver attribute of the 2010 mailbox database where the user is moved to.

do a get-mailboxdatabase |ft identity, rpcclient*

check what is defined there. if it's the server and you have a casarray, do:

set-mailboxdatabase -identity <dbname> -rpcclientaccessserver <casarrayname>

as for the 2003 to 2010 users profile not being updated, once the user is moved, and outlook is unable to connect, autodiscover will give them the correct settings. because you said that you can autoconfigure a profile with <next-next-finish> simple process I will assume that your autodiscover is working correctly.

please check the following setting on the profiles with problems. go to the account settings > more settings > security tab > and make sure that encrypt data between outlook and exchange is ticked. encryption is enabled by default on the server and that might be what's preventing the connection. once the new profile is created the setting is populated correctly.

you can use a GPO to change this to all users if that's your problem.
0
bsohn417Author Commented:
We had an issue with autodiscover that was causing this problem.  The workstations were in one forest and Exchange was in another forest.  The forest the workstations were in already had Exchange installed in it, but for a different company.  The workstations needed to access a remote forest for Exchange.  The workaround for this was to create an autodiscover.domain.com entry in DNS.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bsohn417Author Commented:
Resolved on own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.