RDP Windows 7

I am using Windows 7 Professional and trying to save Remote Desktop Connection Login Credentials.  I had this working before but now I am being prompted for login each time I try to connect.  To get this working before I had to Edit / Enable Allow Delegating Saved Credentials in the Local Group Policy using Gpedit.msc.  It worked fine for a while but just stopped working.   When I try to connect I am prompted for username and password.  If I check off the box: Always ask for credentials, then at least my username will be saved so I only have to type the password.  However, if I uncheck this box then I will have to type in the username and password each time.  Any ideas on how to fix?   Thanks.
LVL 3
fjkaykr11Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nick RhodeIT DirectorCommented:
0
Haresh NikumbhSr. Tech leadCommented:
check if you have allow RDP credentials to saved policy is configured

Open the Group Policy editor (Start > Run > gpedit.msc) and navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Connection Client

For value Do not allow passwords to be saved, change to Disabled.

When connecting to a machine in Remote Desktop Connector, expand the Options panel and confirm that Allow me to save credentials is checked.
0
RogerhatCommented:
I would try and edit the .rdp in Notepad.

http://msdn.microsoft.com/en-us/library/ms861803.aspx

Rhatch
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

McKnifeCommented:
Hi.

Maybe you confuse two things. There is sso and there is "manually" saving credentials.
SSO needs the policy you set. Whenever the checkbox "always ask for credentials" is cleared, it won't ask for credentials but use sso and use your currently logged on user, UNLESS you, at some point before, had already saved credentials of some other user.

If that policy is active but the mentioned box is checked, sso is not used.
I use sso a lot (and I mean like 20 times a day), never have I seen your problem.
0
fjkaykr11Author Commented:
@ Rogerhat that is a neat trick, I tried to add this to notepad but didn't work.
@McKnife, I am not using SSO, this is a different login and pwd for the remote server using RDP.  I don't see the option for Allow me to save credential in the RDP (I thought I had this in there before but I have changed PC's recently, was using Windows XP Pro and now on Windows 7 Pro.
0
McKnifeCommented:
Ok... you don't need that policy at all to be allowed to save credentials. The policy is only about delegating that credentials. I would set the policy to "not configured", do an elevated gpupdate and retry.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fjkaykr11Author Commented:
Thanks for all the feedback.  We changed network policies recently and I think I am going to leave this be for now, I don't want to do anything that is against the rules.   At least I know what might be the cause based on all the good feedback.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.