• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 420
  • Last Modified:

RDP Windows 7

I am using Windows 7 Professional and trying to save Remote Desktop Connection Login Credentials.  I had this working before but now I am being prompted for login each time I try to connect.  To get this working before I had to Edit / Enable Allow Delegating Saved Credentials in the Local Group Policy using Gpedit.msc.  It worked fine for a while but just stopped working.   When I try to connect I am prompted for username and password.  If I check off the box: Always ask for credentials, then at least my username will be saved so I only have to type the password.  However, if I uncheck this box then I will have to type in the username and password each time.  Any ideas on how to fix?   Thanks.
5 Solutions
Nick RhodeIT DirectorCommented:
Haresh NikumbhSr. Tech leadCommented:
check if you have allow RDP credentials to saved policy is configured

Open the Group Policy editor (Start > Run > gpedit.msc) and navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Connection Client

For value Do not allow passwords to be saved, change to Disabled.

When connecting to a machine in Remote Desktop Connector, expand the Options panel and confirm that Allow me to save credentials is checked.
I would try and edit the .rdp in Notepad.


Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.


Maybe you confuse two things. There is sso and there is "manually" saving credentials.
SSO needs the policy you set. Whenever the checkbox "always ask for credentials" is cleared, it won't ask for credentials but use sso and use your currently logged on user, UNLESS you, at some point before, had already saved credentials of some other user.

If that policy is active but the mentioned box is checked, sso is not used.
I use sso a lot (and I mean like 20 times a day), never have I seen your problem.
fjkaykr11Author Commented:
@ Rogerhat that is a neat trick, I tried to add this to notepad but didn't work.
@McKnife, I am not using SSO, this is a different login and pwd for the remote server using RDP.  I don't see the option for Allow me to save credential in the RDP (I thought I had this in there before but I have changed PC's recently, was using Windows XP Pro and now on Windows 7 Pro.
Ok... you don't need that policy at all to be allowed to save credentials. The policy is only about delegating that credentials. I would set the policy to "not configured", do an elevated gpupdate and retry.
fjkaykr11Author Commented:
Thanks for all the feedback.  We changed network policies recently and I think I am going to leave this be for now, I don't want to do anything that is against the rules.   At least I know what might be the cause based on all the good feedback.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now