Cannot view printer properties/add new printer

Cannot view what's currently printing, open printer properties on SBS2011. Have tried restarting the printer spooler and same issue. If I select add printer, nothing happens.

EventLog does not seem to be throwing any errors relating to printing...
SBSWIZARDAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smckeown777Commented:
When did this start happening? I assume it worked last week? If so what has changed on the server?

Can you see the printers in the Printers section? I mean are they listed? What happens when you try to access Properties? Anything pop up at all?
0
SBSWIZARDAuthor Commented:
I am honestly not sure when this started happening as we havent had to make any changes to the printers for a while. As far as I know, nothing has changed on the server as far as hardware/software is concerned. Nothing has been added/removed.

When I select Properties, nothing happens. No error messages. No pop-ups.
0
smckeown777Commented:
Ok, these printers - are they shared? From a client machine when you right click and select Properties can you see everything?

For the sake of it(since its SBS) can you run the Fix My Network wizard so we can check if there is anything listed as broken

Open SBS Console - Network tab - Connectivity
On right hand side is the 'Fix My Network' link - click and report what it finds(don't fix until you post here the results)
0
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

smckeown777Commented:
Oh what about the default 'Microsoft XPS Printer' - can you see the properties of that?
0
SBSWIZARDAuthor Commented:
Sorry. When I select See what's printing, Printing Preferences or Printer Properties, I do not get anything.

But if I select Properties, I get the General and Hardware properties window to come up. This happens on all printers including the Adobe PDF and Microsoft XPS Writer

Yes these are shared printers from the server, not a client's machine.

I get the same issue from the client's machine as well.

Tried to run the Fix My Network tool but it gets nearly all the way done, it crashes - not the server, just the tool.
0
smckeown777Commented:
Oh...well if that wizard crashes then that's not good...

2 things

1) How many NIC's are in the server? If more than 1 - disable the unused ones and try the wizard again

2) You can try to repair the wizard - see this link(related to FQDN settings) - http://support.microsoft.com/kb/2397006

Post the fncw.log file here for review - its located in
C:\Program Files\Windows Small Business Server\Logs\fncw.log

Try step 1 first if you do have more than 1 nic...

Still not sure about the printers...but if there are underlying SBS issues then we need to fix those first to eliminate other issues that might be causing the printing thing
0
SBSWIZARDAuthor Commented:
Disabled unsused NIC - same result.

Attached log file.

One thing, when reading through the resolution for that link you posted, it said to go into EMC...We've uninstalled Exchange since we have moved the client to a hosted Exchange service.
fncw.log
0
smckeown777Commented:
Christ...you uninstalled Exchange? Forgive me but I don't think that is good either...

SBS is a different beast than regular Server 2008 running Exchange...its an integrated part of the product...

Did you get advise on doing that? That would explain the SBS wizard I think...the errors in the last lines of the log file are looking for the IIS sites that normally exist, also looking for the Exchange system...

When did this take place? The Exchange uninstall I mean? Has it been running ok since?

I might need help with this one from other experts...but I don't think uninstalling Exchange is the way to do this at all...it breaks too many things...god knows but it possibly is related to the printers thing...hard to say since I've never seen it done either
0
SBSWIZARDAuthor Commented:
It's probably been a few months since we uninstalled Exchange. Not sure of the exact date. We haven't run into any issues since then that I can really think of, besides this printer issue.

My manager was the one who uninstalled it and a lot more familiar with Exchange and uninstalling it.
0
smckeown777Commented:
Well its not supported...uninstalling Exchange from an SBS box breaks it...put simply

Lets wait for others to comment on this to see where we go next...I'm not sure that the 2 are related but I can't say they aren't - especially if you can't view the properties of the basic default virtual printers on the box...when they don't work its a deeper issue than drivers etc
0
SBSWIZARDAuthor Commented:
Checked permissions on spool folder, restarted server - still cannot get the properties or add printer to come up.

I was thinking about it and I know we have definitely accessed the printer properties from a client's machine within the past couple of months so it has been working since the Exchange uninstall.
0
smckeown777Commented:
After you uninstalled Exchange things might have worked fine for a while...even a month...but eventually the OS stops working...thing stop working

You can't access from client machine now? Same thing happens on the client as when you try from the server yes?

Open Event Viewer - Application and System logs - I guarantee you there will be a lot of errors, mostly AD related...can you export part of the logs here for us to look at?

Run this command on the server

dcdiag /e /v /c /ferr:dcdiagerror.txt /f:dcdiag.txt

Will create 2 files in the directory you are running from, attach those here for review...

You can still open ADUC ok yes? Add accounts and change passwords ok?

Lastly since no one else has commented you can always hit the 'Request Attention' link at top of the question to get the admins to push this question to other SBS experts and things should move along I think...
0
SBSWIZARDAuthor Commented:
Took a look at Application Log - There is only 1 recurring error -

The Module DLL C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll failed to load.  The data is the error.

Source: IIS-W3SVC-WP
Event ID: 2280
Level: Error
User: N/A
OpCode: Info
TaskCategory: None
Keywords: Classic

EventData

  ModuleDll C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll
   7E000000

The above error happens nearly every second.

System Log: Attached. Error repeated by a number of warnings for WsusPool

When running that command I get the following error:

Invalid Syntax: Invalid option /ferr:dcdiagerror.txt.

ADUC works with no issue
sys.csv
0
smckeown777Commented:
Sorry, command line is

dcdiag /e /v /c /f:dcdiag.txt

Attach the dcdiag here thanks...

The errors in App log are Exchange related...also IIS related...again this is the part that's now broken and probably unfixable
0
SBSWIZARDAuthor Commented:
Dcdiag file posted.
dcdiag.txt
0
smckeown777Commented:
Right, can't see anything major in there wrong...

You've a public dns server entry on your nic on the server - remove it as it also is incorrect

4.2.2.2

Only DNS entry should be the ip of the server - no secondary

Reboot server after making that change...can't say its related to your printing issues but no harm in trying

Going to look and see if I can find anything else to check...
0
SBSWIZARDAuthor Commented:
Ok. Thanks smckeown777. You've been extremely helpful.
0
smckeown777Commented:
Ok can't find anything specific...so this is my last option for this...

Have you ever used Process Monitor? Download from here - http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

Run that on the server - it will start capturing events straight away...
Soon as its running go into Devices and Printers and right click on the printer and select Properties

Obviously nothing will happen - go into Process Monitor and click File - and untick Capture Events

Then click File - Save - make sure All Events is selected - save the file to desktop or somewhere
Attach that file here, what I want to see is if there is an error during the OpenPrinterServerProperty event...and hopefully will point to what the cause is...

See how you get on...
0
SBSWIZARDAuthor Commented:
We have moved the printers to another server on the network to manage them and will soon retire the SBS box for an upgrade.

Thanks for all of the help
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SBSWIZARDAuthor Commented:
A resolution could not be found through any means tried through several people. A workaround was put in place instead.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.