RDP break certain windows functions

I have a user that works from home a lot. He uses RPD to get into his computer - Windows 7 64bit. When he RDP's in everything works. Once he disconnects and then attempts to use his PC again, certain Windows functions no longer work even when logged directly on the machine - Windows Explorer, Notepad, Ping, Snipping Tool, etc.

I am not sure even where to start looking for the problem. Any pointers would be greatly appreciated.
Who is Participating?
cantorisConnect With a Mentor Commented:
It looks as though the underlying problem is the length of your path variable.  Shorten it to less than 2048 characters and then it should stick.

Cut out what bits you can and perhaps change some of the longer path components to their 8 character equivalents - eg Progra~1.

More here:
Are you using any form of roaming profile?
I'm presuming not:

What happens if you RDP in to a different local user profile?  Is it OK afterwards on local login?  If that is OK, then perhaps his profile has odd corruption of some sort and he just needs a new user profile.
To confirm my understanding:

Local pc works fine BEFORE using RDP (have the functions been tested prior to rdp?)
what OS is the local pc?
Do they work DURING the rdp seasion?

After the rdp session ends, the finctions listed dont work.
Do they show any errors?
In what way do they not work?
Does this occur when the RDP session is 'disconnected' or ' logged off' or both?
Have you tried RDPing to a different computer/host to see if the same issue occurs?
Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

0PaulieAuthor Commented:
I have not attempted to RDP in using different vreds but I will try.

Everything does work during the initial RDP session. After he logs out and then tries to use the PC again, whether locally or via RDP everything stops.

I had him echo path both before and after and something is removing his path variable. When he does "echo %path% before it breaks:

C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;c:\Program Files\Intel\DMIX;c:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files (x86)\Common Files\Roxio Shared\OEM\DLLShared\;C:\Program Files (x86)\Common Files\Roxio Shared\OEM\12.0\DLLShared\;C:\Program Files (x86)\Roxio\OEM\AudioCore\;C:\Program Files (x86)\Microsoft SQL Server\80\Tools\BINN;C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files (x86)\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\;C:\Program Files\Microsoft SQL Server\90\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\;C:\Program Files\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\ManagementStudio\;C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies\;C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files (x86)\Windows Kits\8.0\Windows Performance Toolkit\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\PrivateAssemblies\

After it breaks:
Aha well spotted!

Do you have any tasks set to run on logoff, or logoff scripts assigned to the user through group policy?
0PaulieAuthor Commented:
He does not have any scripts but his ad account is quite old. I am going to do some testing with other creds this afternoon to see if they cause the same problem.
0PaulieAuthor Commented:
I have more information but still no idea

1. This is not profile specific. Behavior is the same for any user

2. It only happens if you RDP into the machine while logged on locally as well. For example the user locks the computer and goes home. He RDP's in from home and it removes the path.

3. RDP in when not logged in locally does not remove the path,

4. I was wrong in one of my answers above. The initial RDP session does not work. I misunderstood when he was telling me.

5. No roaming profiles

6. Here is the kicker - If user A is logged in locally and user B RDP's in, user B's session works fine. After user B disconnects and user A reopens his local session the path is gone for user A.
0PaulieAuthor Commented:
I just learned that this all started just after the user installed SQL server 2012 and Visual Studio 2012. He had some trouble installing these and had to remove and re-install multiple times.
yep that sounds about right.
I believe when you RDP it amends the path variable a little to include a few extra items for the session.
if this pushes the variable over the limit it will probably break it.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.