Group Policy - copy File to all users - My Documents

I am trying to copy a .ini file to all users that belong to a security group.

I have uses GP Preferences to push the file to the users, it just dosent seem to work.

The GPO is as follows:

Source file(s) \\server-apps\GPO_Install\aurora.ini (Location all users can access)
Destination file %userprofile%\documents

Attributes
Read-only Disabled
Hidden Disabled
Archive Disabled

This GPO is set on User Preferences and I know that part of the GPO is making it (Using a Computer Preference to create a shortcut on desktop)
Travis HahnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

piattndCommented:
Use this link to check the logs for more detail around the failure:

http://technet.microsoft.com/en-us/library/cc775423(v=ws.10).aspx

If it were me, I'd probably just create a vbscript and associate that as a login script via GPO for the users in the security group.
0
seanabCommented:
From a client computer that is supposed to get the file via a policy run the RSOP on it and see what it says.  It might be blocked by another policy.
0
Travis HahnAuthor Commented:
I had done that earlier and it shows that the policy was applied to the user and filtered out on computer.

The two settings are set on the user preferences.  However the ini file will not get created.

And this policy is set to all authenticated users


So is there a restriction on the GP that only allows Computers Preferences to copy files and not on a user basis.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

piattndCommented:
As long as the user account has permissions to read from the source and create/write to the destination, then you should be fine.

If you try to manually copy and paste the files from that location to the new location as the user, do you get any errors?
0
Travis HahnAuthor Commented:
Just tried that and doing a copy command was successful.

AWWW = I hate GPO sometimes.
0
seanabCommented:
you might have to apply the GPO to an OU that contains the computers of the systems that you want this file copied to. Note the default computers container cant have GPO's  linked to it.
0
Travis HahnAuthor Commented:
The GPO is applied to a container that houses both the users and computers
0
seanabCommented:
That might be your issue right there. Having both users and computers in the same OU causes GPO's to behave a little differently since you have both computer and user policies defined. You might have to enable loopback in this case. EDIT: I've never used the loopback feature so i'd wait til someone else chimes in on that or perhaps read a bit about it here: http://support.microsoft.com/kb/231287
0
Darrell PorterEnterprise Business Process ArchitectCommented:
Bluntly, follow good practices and re-organize Active Directory.  Unless you have some specific business-driven need to mix user and computer objects within the same container, they should be placed in their own, appropriate containers and managed appropriately.  GPOs are not the only aspect of Windows Administration that acts oddly when user and computer objects are located in the same container.

Ensure that NT AUTHORITY/SYSTEM has permissions to write to the destination and read from the source as well.  Test this using PSEXEC -i -s cmd.exe on a target machine and determine if you can copy the file from the UNC path to the desired destination without error.
0
Raj-GTSystems EngineerCommented:
Try the following in GPP for the entry.

General tab: Change Action to replace
Common tab:  select "Run in logged in user's context"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Travis HahnAuthor Commented:
Just for clarification - see the attached.  I believe that my AD structure is fine and the GPO I am trying to apply is being linked to the Top Level "Administration" OU.  

RAJ-GT I will give it a shot.
ADCapture.PNG
0
Travis HahnAuthor Commented:
Thank You
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.