Port forwarding through 2 routers

Port forwarding failing.  Here is the info:

1. I have a remote client (too far away to visit) who needs port 8400 forwarded to a local workstation for remote users.  

2. They have their ISP's DSL (I think it's a 2wire model) set up as a router (DHCP issuing LAN IP addresses on 192.168.2.xxx).  No local clients are using this except...

3. ...They have a cable coming out of the ISP's lan port to the WAN port of a Linksys router.

4. The Linksys router has a WAN IP of 192.168.2.10 and works fine - everyone connected to the Linksys is getting on the Internet.

5. The Linksys DHCP is issuing IP's on 192.168.1.xxx.  (Not sure why they have this particular router-to-router setup)

6. To make port forwarding work, on the ISP's router I forward port 8400 to the Linksys WAN IP (192.168.2.10). On the Linksys, I also forward 8400 to the IP address of the desired workstation 192.168.1.105.

I cannot communicate over port 8400.  I've done this before with another client and it was as smooth as silk. What am I missing?

Thanks for any help.
Dave
LVL 1
DaveWWWAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

piattndCommented:
Why not turn the modem into passthrough mode so it doesn't act as a router, since you already have one?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TomRScottCommented:
The forwards sound correct.

I would drop the DHCP on 192.168.2.0 since you only have the static IP of the Linksys router to support, making DHCP services redundant. Or, as Pia suggests set it up as pass through.

Moving to pass-through, if the unit supports it does simplify things a little but you lose one method of creating a guest LAN outside your internal Office LAN.

Some diagnostics to consider:
1 - Have someone local test connecting to the the workstation using port 8400 from within 192.168.1.0.
2 - If 1 is successful, try the same from within 192.168.2.0.
If 1 fails, I would look for a possible personal firewall or other security software on the workstation that may be blocking the desired port.

 - Tom
0
vivigattCommented:
I have a similar setting working :  I even forward ALL ports to the second router, which is not a real router, but a NAT gateway, and so are yours...

The tests proposed by TomRScott seems relevant to me.
In order to check ONLY port 8400, you can use a telnet command to the exposed IP address.
From "the Internet":
telnet <ISP's public IP address> 8400
From "192.168.2.x":
telnet 192.168.2.10 8400
From 192.168.1.x:
telnet 192.168.1.105

If you have the same results each time, it might mean that port forwarding is working OK but that you actually need more ports to have the application/service/daemon listening on TCP/UDP 8400 on 192.168.1.105 working as expected.

BTW: be careful, forward UDP/TCP 8400 accordingly to the settings of the app/service/daemon. If you don't know, forward both!
0
DaveWWWAuthor Commented:
Hello all, and thanks for the help.  I was not able to test from within 192.168.2.0 except from the 192.168.2.1 router, which was able to reach the router at 192.168.2.10, since I was remoted into that 2nd router which was issuing IP addresses on 192.168.1.0.

Anyway, I agree with TomRScott that it "sounds" correct, and in fact I am doing this exact arrangement with another client with no problems at all, and basically sets up a guest network.  And inside the clinic, other workstations are communicating with the router over 8400, so it is a matter of traffic not making it through.

Because I have no need for the two router arrangement, I set the innermost router to PPPoE, saved the settings and had them reset the first router, which defaults as a DSL modem upon reset.  The problem was solved. :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.