Sometimes pages load, sometimes they load incompletely

When I say they load incompletely, it appears the code shows on the screen, rather than the way the content was intended to display.  Reloading often brings the page up as expected. This happens most often on msn.com, perhaps because it's my home page.  It happens on other pages too.  Simpler pages, like google.com load without issue.  Is something timing out?  Am running Windows 7 and IE 10 with current patches.  Runs the same way on several different WLANs with plenty of bandwidth. As I write, I really haven't tried a wired connection.  This has been a problem about 2 months on a 2 GB Dell D620 I've been using with a SSD for 2 years.
Running K7 antivirus - finds no problem, MalwareBytes - finds no problems.
HerrBallAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PJL2Commented:
Try another browser(chrome, firefox etc). If it works ok, then you can formulate a plan to resolve issue. Have you tried resetting IE in "Internet Options" (under the advance Tab)?
0
Skyler KincaidNetwork/Systems EngineerCommented:
IE 10 has been showing issues with a lot of our clients. I would also recommend trying a different browser to see if you can recreate the same issue, I prefer Chrome.

You can also go to Add/Remove programs > View install updates > and remove the IE 10 update to roll back to IE 9.
0
HerrBallAuthor Commented:
Thanks for the suggestions.  I downloaded Firefox and don't see it doing the same things.  It acts as I would expect, however I haven't used it more than an evening.

Will continue to use it as I try the IE suggestions.  I'm not seeing the problems I have described on other Windows 7, IE 10 machines I use.
0
PJL2Commented:
Did you try using compatibility view? It should appear in the address bar (far right) as a tiny icon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HerrBallAuthor Commented:
sorry for the delay. Bottom line is that Firefox works fine, Got busy and haven't really had time to drill down into the IE solutions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Protocols

From novice to tech pro — start learning today.