provider is not registered on the local machine

Hello Experts,

I'm new to web services and connecting to Oracle.  I am using Oracle Express Edition 11.2.0.2.0 and running on Windows 7 64 bit machine.  the connection string I'm using is:

Provider=OraOLEDB.Oracle;Data Source=XE;User ID=system;Password=pwd01

I get the following error when the web service tries to connect to the DB:

System.InvalidOperationException: The 'OraOLEDB.Oracle' provider is not registered on the local machine.
   at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
   at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
   at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup)
   at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
   at System.Data.OleDb.OleDbConnection.Open()
   at RealPropertyWebServices.clsDataAccess.OpenDatabase() in C:\Users\kmfrancis\Documents\Visual Studio 2010\Projects\RealPropertyServices\RealPropertyApplicationSolution\RealPropertyWebServices\clsDataAccess.vb:line 6984
   at RealPropertyWebServices.RealPropertyWebServices.GetDocumentTypes() in C:\Users\kmfrancis\Documents\Visual Studio 2010\Projects\RealPropertyServices\RealPropertyApplicationSolution\RealPropertyWebServices\RealPropertyWebServices.asmx.vb:line 189

What am I doing wrong?
mutuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Carl TawnSystems and Integration DeveloperCommented:
Did you install the Oracle client tools on the machine too?
0
slightwv (䄆 Netminder) Commented:
I'm going to make a couple of assumptions:
The .Net web service is 32Bit.
Your Oracle install is 64Bit.

If so, you need the Oracle 32Bit OLEDb drivers.

You can download them from:
http://www.oracle.com/technetwork/topics/dotnet/downloads/net-downloads-160392.html

Just to confirm:  The web service is running on the same server as your XE instance.  Correct?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mutuAuthor Commented:
Yes the .Net web service is 32Bit and the web service is running on the same server as the XE instance.  The Oracle install is 32Bit - I don't think Oracle has a 64Bit version for 11.2.0.2.0.  

I will download the drivers and try it ...

Thank you for your help!
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

mutuAuthor Commented:
Carl_tawn - What are the client tools and where do I get them?
0
mutuAuthor Commented:
I downloaded the Oracle tools and ran the sql scripts but I still get the same error and I don't know what else to try!
0
slightwv (䄆 Netminder) Commented:
It's been a while since I had to install the drivers but I remember there being an install process of some sort for the OLEDb drivers.

Did you run that?

There should be a readme type file as part of the unzipped download that tells you how to install them.
0
Carl TawnSystems and Integration DeveloperCommented:
In Windows go to:

  Start > Settings > Control Panel > Administrative Tools > Data Sources (ODBC)

Look under the "Drivers" tab. What, if anything, is listed for Oracle?
0
slightwv (䄆 Netminder) Commented:
>>Look under the "Drivers" tab. What, if anything, is listed for Oracle?

I can install the OleDB drivers and not the ODBC drivers.  Not sure what looking for the ODBC drivers will help solve.
0
mutuAuthor Commented:
Under the Drivers tab there are two items listed:

SQL Server
SQL Server Native client

I looked at the readme file but didn't see anything about ODBC drivers.  I'm going to look at the readme file again to see if I missed anything and I will look into ODBC drivers.
0
slightwv (䄆 Netminder) Commented:
>>if I missed anything and I will look into ODBC drivers.

I suggest not using ODBC.  They are problematic and typically have limitations that other native drivers do not have.

If you are considering changing drivers, I suggest ODP.Net.
0
mutuAuthor Commented:
Experts thank you for all your help!!  This is a 64 vs 32 bit conflict.  The problem went away when I enabled 32 bit applications in IIS.

1. Start IIS (Start -> type inetmgr in search box)
2. Click on Application Pools in left panel, list of Application Pools will display in right panel
3. Select DefaultAppPool and name of the virtual directory of the app then click on Advanced Settings in Action Panel under Edit Application Pool.
4. Enable 32-Bit Applications = True for both

I will accept solution and award points.
0
mutuAuthor Commented:
Your comments were helpful to narrow the search for a solution.  Thank you very much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.