Enable Data Connections for all users

I have an excel file installed on a server machine that users access through a citrix environment.

This Excel file connects to an Oracle database and displays the results of a select statement.  The problem is that every time the file is accessed Data Connections have to be turned on.  

I can "Enable all Data Connections" in the Excel Options => Trust Center => External Content so that it doesn't come up anymore, but this is for the logged on account only.

Is there a way I can set this so that every new user wont have to go through this process??  i.e. enable Data Connections on this file for all users???
obrienjimmyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zaheer IqbalTechnical Assurance & ImplementationCommented:
This is possible via a GPO, Please configure via Group Policy what version of excel are you using?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
obrienjimmyAuthor Commented:
We're using Excel 2007.  
Just looking up about Group Policy. Should be able to get that done.  Just to clarify, once that is set, it will apply to any Excel document that's opened... not just the one I want to have data connections open for.  Is that correct?
0
obrienjimmyAuthor Commented:
Is there a setup involved in using Group Policy?  Or is it on by default?
0
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Zaheer IqbalTechnical Assurance & ImplementationCommented:
0
obrienjimmyAuthor Commented:
I'm not an admin of the server machine in question.  If this isn't already set up, then it's probably not an option for now.

Is there a way I can quickly tell if there is any group policies set up on the machine while logged on as a normal user?
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Please ask your server admins / active directory team.

You can do Gpresult on the machine in question
0
obrienjimmyAuthor Commented:
Okay, I have it confirmed that the Group Policy setup here comes from a global script, so close to zero chance of doing any modification to that.  Thanks anyway, I'll just have to train people to update it on first use.
0
BUnitedCommented:
Old issue, but this is a complete solution for posterity.

The Excel setting is not in the standard Office 2010 or 2013 GPOs from Microsoft.  It can be set via a registry setting directly in HKCU Office keys or the HKCU Policies Key.  We use ScriptLogic Desktop Authority for user settings, but writing a classic ADM template is easy enough.  This is a reg file for what I set for Excel 2010 and 2013 Trust Center External Content:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Excel\Security]
"DataConnectionWarnings"=dword:00000000
"WorkbookLinkWarnings"=dword:00000000

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Excel\Security]
"DataConnectionWarnings"=dword:00000000
"WorkbookLinkWarnings"=dword:00000000
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.