• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3929
  • Last Modified:

Virtual Machine (VMware), DHCP not working


I am running a Windows Server 08 R2 on a VM
After installing & configuring DHCP, I am noticing that it does not lease any IP addresses.
Entering a static IP to a host will allow me to have a connection, ping the server ect...

VM DHCP service is running (has been restarted too), Host is has DHCP client running OK

VM is directly bridged to the network

Scratching my head over that one. not sure why it is not working!

1 Solution
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
VMware DHCP Service is only relevant to NAT and Host networking.

If the VM is Bridged, it should issue IP Addresses via DHCP.

You could stop the VMware DHCP Service on the host.
defreyAuthor Commented:
no didnt do the trick!
Based on experience about your description I things this is your scenario:

A properly working network with all required services but need to re-group services to a better server or not so loaded one... or just to one server down to upgrade it.

Your server might not lease new ones as is not the only one on the network and current leases will always try to renew in the current server address before the lease is due.

To be sure your VM settings are correct you have two paths:

1.) Make this VM server your only DHCP server on the network and see if the server allocate addresses. (Might impact users access to network)

2.) Divide and conquer!!!, make your VM server to lease lets say half of your scope. Replace your other DHCP server settings to renew IP faster and exclude the range the VM server will be covering.  Soon you will see the server populating leases.... repeat the process to leave the VM server as your only DHCP on your LAN.  (A little slow... may required more time but recommended)

If time is an issue, then stop actual DHCP and force all users to reboot.... done deal... !!

Good luck!!

If that doesn't work, check if your settings include the DNS server's IP in the scope options in your scope.

If it works... then your issue is that you have another DHCP server taking over your settings on this one.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now