SBS 2008 - VPN


I have enabled VPN on my SBS 2008 server and I have gone to a Windows 8 client based on a remote site and created a connection successfully.
The Windows 8 client connects successfully using the network administrator login details and also using a normal SBS user login details. The connecting bit is fine.

When I have connected to the VPN using my network administrator details, I can browse the documents on the SBS 2008 server by typing in \\\ and I have no problems.

But when I connect to the VPN using a normal SBS user details, then I can connect okay but I cannot browse any files. When I do \\\ I get an error.

Many thanks
Who is Participating?
ShaneConnect With a Mentor Commented:
I would maybe try and eliminate some complexity.  
1. Can the user access the file share when logged on locally to a computer (not via VPN)?  If not, then you probably need to modify sharing/security permissions of the share on the server.
2. Try creating a share on a server that is listed as a computer.  Then try and log in as the user (locally, not across the VPN and not the same server that is hosting the share)  and see if you can access the share.  If you can, try and log in as the user over the VPN and see if you can access the share.  
You need to determine if the problem is sharing/security permissions or something else.  Hope that helps.
What type of error do you get - ie what is the error message?  If it's just that you can't see the files, does the 'normal' user have access to the files when logged on locally?  Access based enumeration hides files from users view if they don't have permissions to read the file.
amitkheraAuthor Commented:
I have connected using the credentials of the normal user and it says VPN connected.
When I go to browse the files, I type in \\\ and it gives me the following error. I have attached a screenshot.

But when I do the same by using the administrator credentials then I can browse through the files with no problem
Try looking in the SBS console, under "Users & Groups" - check the properties of the user and go to the computers section.  Check that they have remote access to the computer. See attached screen shot.
amitkheraAuthor Commented:
I have checked it all. Under users and groups the user has VPN enabled. the user needs access to a folder on the server and the server is not on the list of Computers that the user has remote access to. The server does not exist in the list at all.
Now what can I do?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.