• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1232
  • Last Modified:

Exchange 2003 OWA giving 404 - File or Directory not found

We have 1 Exchange Server 2003 co-existing with 1 CAS and 2 Mailbox servers.

Exchange 2010 mailbox users CAN use Exchange 2010 OWA, but gets below error when log into Exchange 2003 OWA

     404 - File or Directory not found. The resource you are looking might have been    
     removed, had its name changed, or is temporarily unavailable.

Exchange 2003 mailbox users CAN use Exchange 2003 OWA, but gets below error when log into Exchange 2010 OWA.

     Your request couldn't be completed because no server with the correct security
     settings was found to habndle the request.      

Below is configured.

- Smart host is still on Exchange 2003

- Configured Exchange 2010 OWA, ECP, Exchange Active-Sync with below ONLY FOR INTERNAL URL, as our company uses owa only for Internal, not external

       Internal URL: mail.company.com

      Set-OABVirtualDirectory –Identity “CASserver\OAB (Default Web Site)” –InternalUrl https://mail.company.com/OAB -RequireSSL:$false

       Set-WebServicesVirtualDirectory –Identity “CASserver\EWS (Default Web Site)” –InternalUrl https://mail.company.com/EWS -BasicAuthentication:$False

- Result of Get-OWAVirtualDirectory

   owa           CAS server name     owa Version as Exchange 2010.

- On internal DNS;
    A record for legacy.company.com
    A record for CAS server
    A record for mail.company.com
    A record for AutoDiscover.company.com

Appreciate your help

1 Solution
Just try to restart IIS and give a try
xpert_aliAuthor Commented:
Sure will try, but after our business hours. As "cant afford" to do so right now :)

Will update here.
xpert_aliAuthor Commented:
Restarting IIS on CAS server did not help. Same above 2 error experienced.
Simon Butler (Sembee)ConsultantCommented:
Looks like the legacy configuration isn't correct.
Start by going through this article:

Check everything, don't presume anything.

I would also look at moving the smart host delivery to Exchange 2010 (AS well as inbound SMTP delivery) Rule of thumb is to use the highest version you can as soon as you can.

Here is the fix for this.

legacy.domain.com needs to point the EX2003 front-end box (I assume you have already configured public DNS and NAT on your firewall). If your front-end box has multiple IPs/websites, it needs to resolve to the IP tied to the Default Web Site.

Form based authenticated needs to be enabled. Here are the steps:

1. On the Exchange server, log on with the Exchange administrator account, and then start Exchange System Manager.

2. In the console tree, expand Servers.

3. Expand the server for which you want to enable forms-based authentication, and then expand Protocols.

4. Expand HTTP, right-click Exchange Virtual Server, and then click Properties.

5. In the Exchange Virtual Server Properties dialog box, on the Settings tab, in the Outlook Web Access pane, select the Enable Forms Based Authentication option.

6. Click Apply, and then click OK.

I fixed mine a few mins ago and now Legacy redirection from EX2010 to EX2003 is now working
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now