configure settings in remote desktop connection

While setting up an office member to be able to work from home we are having issues getting his local controls to carry over to his remote session. He comes into the network through a Cisco VPN connection and then uses remote desktop connection to connect to his local PC here. He is left handed and has the mouse properties switched on the buttons but in his connection while showing to be switched they are revert back to factory defaults. Going into the mouse properties does not correct the problem and nor does checking and adjusting settings the local resources tab on the remote desktop connection either. Also his local printer at home is not showing up for him to be able to print to his local printer at home while working through remote desktop. We have tried logmein.com and are able to make everything work properly through that but the connection speed is much slower and handicaps his ability to do work.
jpapetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

piattndCommented:
Have you checked the remote session for any profile errors?  Do you have the remote session set to get rid of local profiles upon logoff?  If so, are you implementing a roaming profile for this user?
0
jpapetAuthor Commented:
The remote session is set to accept settings from the local resources and there is only the one profile set up to use it. And the profile is a domain profile that is being logged into.
0
piattndCommented:
I'm not talking about the account, I'm talking about the actual profile.  In active directory on the profile tab, does this particular user have a roaming profile?  If you have the user log off the remote session and you login as a different user, do you see their local profile inside of the users or docs and settings location?  Does the user have their host system configured for a left handed mouse?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

jpapetAuthor Commented:
sorry for the confusion, no the profile is not a roaming profile. yes his profile is in the users location. and yes the user has the host system also configured for a left handed (buttons switched) mouse.
0
piattndCommented:
Ok, and you don't have any software that resets the machine after a user logs off, such as steadystate or anything of that sort, correct?  Do you have any GPOs applying to this users account or the computer account that would force a right handed mouse?

Have the user go into the registry in the remote session and go to the following registry key:

hkey current user\Control Panel\Mouse

Set the value for "SwapMouseButtons" to 1 and close regedit.

Have the user log off and log back on to confirm the settings stayed this time.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jpapetAuthor Commented:
Thank you so much, that fixed the mouse issue but I do still have the printer issue that I cannot get straight.

Edited for clarity

The local printer is not showing up in the print dialog as a redirect. The same brand and model printer is at both locations so it is not a driver issue I do not think. The home location printer is shared and the box is checked for it to show up in the directory too.
0
piattndCommented:
Do you see the printer listed in the printers view in control panel within the remote desktop session?
0
jpapetAuthor Commented:
Yes all of the printers both local and network printers are in the printer view but the remote host (redirect) printer is not showing up.

sorry to clarify after re reading your question no the printer does not show up in that printer view window.
0
piattndCommented:
Do you see any events listed in the application log that indicate failure to bring over the printers from the original session?  If so, can you post those here please?
0
jpapetAuthor Commented:
I was not able to find any reports in the application log referencing the printer. I asked him to specifically mark the time of his log in this evening so I can check the logs in the morning to see what happened. I will report back then what I see. I do appreciate all of your help.
0
jpapetAuthor Commented:
The event on the remotePC when trying to print through remote desktop reads as follows:

Faulting application name:spoolsv.exe, version: 6.1.7601.17514, time stamp: 0x4ce7b4e7
Faulting module name: LMIport.dll, version: 0.2.0.0, time stamp: 0x517a8bdb
Exception code: 0xc0000005
Fault offset: 0x00000000000045f0
Faulting process id: 0x590
Faulting application start time: 0x01ceb951ff7e0089
Faulting application path: C:\Windows\System32\spoolsv.exe
Faulting module path: C:\Windows\System32\LMIport.dll
Report Id: fb3df4f1-2564-11e3-864e-c89cdcaa737f
0
piattndCommented:
I'm not sure if you fixed the printer issue, but I'd check to see if the host system is 32bit or 64bit and compare that to the remote session.
0
jpapetAuthor Commented:
both are windows 7 pro 64 bit systems
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.