• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 645
  • Last Modified:

Disable wireless when connected to LAN

I have a Dell System Vostro 3450 running windows 7. When I connect to the LAN, I also stay connected to the wireless. This is giving me network issues because the computer will go back and forth between the two differen't nics and the wireless is on a seperate vlan.

Dell says there is no supported settings to change in the bios that will automatically disable wireless when connected to LAN. Is there some other alternative for this?
1 Solution
Did you try to  change the Network Adapter priority (with the ALT button)?
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
You can Create a Scheduled Task to Auto Switch

Using this method relies on your computer’s LAN adapter sending an event to the Windows Event Viewer when it disconnects and reconnects. With this information you can then create tasks to disable or re-enable the Wifi adapter depending on the connection status of the wired connection. This does not work on Windows XP because it doesn’t have the option to trigger a task when a specific event is logged.

1. Go to Control Panel -> Administrative Tools -> Event Viewer. When Event Viewer is open, go to Windows Logs -> System.

Joe Winograd - EE Fellow & MVEDeveloperCommented:
Hi Allanore,
In theory, Windows is supposed to pick the fastest connection available. Here's an interesting thread that talks about it:

The article states that you may force Windows to use a specific network connection by assigning a metric value to all of the connections, giving the lowest (best) value to the desired connection. My personal experience, which is the same as the "back and forth" you describe, is that Windows doesn't always get it right, and I sometimes found it using the wireless connection even when it had a (faster) wired connection. So I've taken to disabling the wireless connection when I'm wired. I realize you'd like it to do that automatically, but I'm not aware of a way to do that. However, a simple way to do it is to put a shortcut to the wireless adapter on your Start Menu and/or taskbar and/or desktop as follows:

Control Panel
Network and Sharing Center
Change adapter settings
Right-click on the wireless adapter and select Create Shortcut

It will say that it can't create the shortcut there and ask if you want it on the desktop instead...click Yes. You may then copy/paste the shortcut onto your Start Menu and/or pin it to the taskbar (or cut/paste if you don't want to leave it on the desktop).

This shortcut will act as a toggle for the wireless adapter. When the wireless adapter is enabled, this shortcut will bring up a dialog box with a disable button...simply click it to disable the wireless. When the wireless adapter is disabled, this shortcut will automatically enable it. Regards, Joe
Control Panel - Network and Internet - Network and Sharing Center, then on the left manage network connections and right click on your wireless network and click disable :) when you disconnect the lan, enable using the same steps !
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now