samba version 3.6.9-151.el6_4.1 Red Hat 6.2

moving our database (Universe)  to a new server running Red hat ES6 64 bit version and our old server was a Red hat 9 running samba version 2.2.7a. I need Samba so that it can write to a temp file to allow tiff images to be delivered to them via a tiff viewer. The older version of samba works great, but this new version I am unable to get the share to be able to write. I can view, just cannot write. any help would be greatly appreciated.

here is a copy of my samba config. this is from my older Samba v2 that I copied over to the Samba v3. I have tried uninstalling samba then reinstalling it, using the config that comes with samba. When I try to UNC into the share I can get it, just cannot create a file, or folder. says that I do not have permission. Everyone should have read and write to the temp file.

[global]
      log file = /var/log/samba/%m.log
      load printers = yes
      force directory mode = 0777
      encrypt passwords = yes
      winbind trusted domains only = yes
      public = yes
      winbind use default domain = yes
      dns proxy = No
      writeable = yes
      printing = cups
      server string = samba server
      force security mode = 0777
      force create mode = 0777
      os level = 20
      auto services = global
      update encrypted = Yes
      printcap name = cups
      create mode = 0777
      security = share
      max log size = 100
      directory mode = 0777

[ccc]
      guest account =
      create mask = 0777
      browsable = yes
      path = /uv/ccc

#from old server, this wont work with Samba ver 3
#[ccc]
#      comment = upload files
#      path = /uv/ccc
#      read only = No
#       writable = yes

[homes]
      comment = Home Directories
      valid users = %S
      read only = No
      create mask = 0777
      directory mask = 0777
      browseable = No

[printers]
      comment = All Printers
      path = /var/spool/samba
      printable = Yes
      browseable = No
      available = No

[cawportal]
      comment = CAW data files
      path = /uv/cawportal
      valid users = jsheldon
      read only = No

[temp]
      comment = temp upload for imaging
      delete readonly = yes
      writable = yes
      path = /uv/cubs/temp

[cudocuments]
      path = /uv/ccc/cudocuments
      guest account = cubs
      force user = cubs
      force group = cubs
      read only = No
      delete readonly = Yes
LVL 1
tjguyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MazdajaiCommented:
Can you post the following ?

ls -lah /uv/cubs/temp

Open in new window

0
My name is MudSystems EngineerCommented:
19.7.2. Share-Level Security

With share-level security, the server accepts only a password without an explicit username from the client. The server expects a password for each share, independent of the username. There have been recent reports that Microsoft Windows clients have compatibility issues with share-level security servers. Samba developers strongly discourage use of share-level security.

In smb.conf, the security = share directive that sets share-level security is:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tjguyAuthor Commented:
this issue was the SELinux blocking all clients to the shared folders. once I disabled SELinux the Samba Shares started to work again as expected.
0
tjguyAuthor Commented:
after scanning the log I noticed that smb shares were being blocked by something called selinux.

chcon -R -t samba_share_t also seem to help this issue as well. Still disabled SELinux.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.