Unable to demote DC with dcpromo

Server 2008 R2. When running dcpromo trying to remove AD from DC, I am getting an error "insufficient attributes were given to create an object. This object may not exist because it may have been deleted and already garbage collected." Every time I run dcpromo, a different server is listed as DC having a problem being reached. All servers in domain are operational
nfinorthitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
This can be a very complex issue, according to everything I've read, and is related to replication issues. You can take a look at this post and see if it helps you at all:

http://social.technet.microsoft.com/Forums/windowsserver/en-US/44edd391-17df-4cd4-a883-4ee7fce636be/active-directory-replications-problem

I'm inclined to advise that you call MS support rather than trying to troubleshoot this on EE.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nfinorthitAuthor Commented:
I did a forced dcpromo and it worked fine. Thanks.
0
nfinorthitAuthor Commented:
The link you provided gave a suggestion to do a dcpromo /forceremoval, which worked in my situtation.
Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.