Ldifde Command Error

Command Below is what I run:

ldifde –f "C:\Nandhini.txt –d “CN=Nandhini, OU=Users, DC=contoso,DC=com”

I get this error message.
Invalid Parameter: Bad argument '-f'

Example: Macro expansion in DNs
    ldifde -f export.ldf -c "#configurationNamingContext" "cn=configuration,dc=x"
    ldifde -i -f import.ldf -c "cn=configuration,dc=x" "#configurationNamingContext"

No log files were written.  In order to generate a log file, please
specify the log file path via the -j option.

Can someone help me get this output file of the user.txt.
Who is Participating?
BxozConnect With a Mentor Commented:
Can you try to copy/past that i try myself without any issues

ldifde -f c:\Nandhini.txt -d "CN=Nandhini, OU=Users, DC=contoso,DC=com"

Open in new window

Don ThomsonCommented:

ldifde –f C:\Nandhini.txt –d “CN=Nandhini, OU=Users, DC=contoso,DC=com”

You can never have three "  in an expression - they have to be in matched pairs and are only used when the file name has a space in it  such as "C:\my Documents\..."
If the file name doesn't have a space the quotes are unnecessary
shorisAuthor Commented:
tried that I still get that error above grrr.

No log files were written.  In order to generate a log file, please
specify the log file path via the -j option
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Are you sure about your hyphen ? It seems more like a dash.
There is a little difference between –f  and -f
I noticed the same thing as Bxoz did with the hyphen vs dash.  The longer hyphen shows as hex 96 and the dash as hex 2d in a hex editor.  In a web page it is converted to  –f   whereas the short dash  -f  is just displayed literally.   It's more apparent in large font in a screenshot.
Hex 96 left, hex 2d right
Hello Shoris,

Can you give us any feelback ?
shorisAuthor Commented:
it worked.. sorry for the late response.. thank you so much. I had been travelling.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.