RD Web Access Remote PC Opton not available when logging in Externally

External BrowseInternal BrowseRAPWe have done upgrades of our servers from Windows Server 2012 Essentials to Standard using In place upgrade. As part of that process I am configuring RD Web Access. I have a few roadblocks and require assistance. The end result is for the users of a group (engineers) to have access to their remote desktops. I have:


1. Configured the RD Gateway
Created a connection authorization policy and Resource Authorization Policy
Created a Resource Authorization policy.
Added computers to the locally stored groups


When I access the RDWeb page from IIS  ( Browse Servername on *.443 (HTTPS) I am able to get to the " Connect to a remote PC page"  however when I connect via external web using https://remote.servername.com/RDWeb/ the connect to a remote PC option is not available.


My thought is that I am missing something here. Attached are the screen shots.
KarlSolidAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcneil4Commented:
I'm having the same issue!  did you find a resolution yet?
0
jcneil4Commented:
Figured it out.  You have to specify the RD gateway server in the RD Web configuration.

On your RD Web Access server, please open IIS Manager.  In the left pane, please navigate to and select Sites\Default Web Site\RDWeb\Pages.  In the middle pane, double-click on Application Settings.  Please double-click on DefaultTSGateway and enter the FQDN of your RD Gateway.  

-Note your gateway needs to have a public FQDN and allow https (443) and RDP (3389) from the outside.


After making the above change please refresh the RDWeb page on the client and then test by trying to use the Connect to a remote PC tab from an external PC.

Also it seems that you need to be using IE to get this tab.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.