Exchange 2010 Active Sync Timeout Warnings

Hello,

I am getting this warning message on an Exchange 2010 server running on Windows 2008 R2

All roles are installed on this one server, we have increased the firewall HTTPS timeout to 1 hour and the server IIS time out to 30mins but to no effect. Firewall used is Juniper.

IIS setting changed is in the Default website - ASP - Session Properties - Timeout

Log Name:      Application
Source:        MSExchange ActiveSync
Date:          26/09/2013 9:57:58 PM
Event ID:      1040
Task Category: Requests
Level:         Warning
Keywords:      Classic
User:          N/A
Description:
The average of the most recent heartbeat intervals [470] for request [Sync] used by clients is less than or equal to [540].
Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and direct push technology. Specifically, make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed.

For more information about how to configure firewall settings when using Exchange ActiveSync, see Microsoft Knowledge Base article 905013, "Enterprise Firewall Configuration for Exchange ActiveSync Direct Push Technology" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905013).
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchange ActiveSync" />
    <EventID Qualifiers="32772">1040</EventID>
    <Level>3</Level>
OZSGGeneral Manager Technical ServicesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nick RhodeIT DirectorCommented:
Usually if you increase the timeout on your HTTP(S) on your firewall (router), this issue tends to go away.  I think the minimum recommended is like 15 minutes.  If this is already set to minimum or higher then check IIS connection timeout for the default website.

When the settings were adjusted did you do a quick restart?  Or do an iisreset /noforce

In all honesty it does not mean anything is wrong, it just means a phone timedout (maybe weak signal or just a bad phone) when attempting to tell the server it can recieve mail etc.  Do you perhaps have a specific user that complains about their phone?  Or is this all users phones connected to exchange.  You could resetup the account on the users phone if you can single them out.
0
OZSGGeneral Manager Technical ServicesAuthor Commented:
Hi NRhode

Where can I check IIS connection time out for the default website?

Yes I did restart IIS after I made the changes.  Right now session time out is set at 30mins and the firewall is set to an hour according to the firewall admin.

Was I right to set the setting I mentioned in my initial post?

The warning message is really annoying so far no users are complaining that they can not receive email or it is slow for them to get email on their mobile devices
0
Nick RhodeIT DirectorCommented:
This is interesting:  http://social.technet.microsoft.com/Forums/en-US/fb1811eb-0961-4eff-8ce1-dd2f322cc972/event-id-1040-activesync.  Also keeping them at 30 on the firewall is fine.

What version of exchange is currently installed?  Like which service pack?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

OZSGGeneral Manager Technical ServicesAuthor Commented:
The current version is with SP1 I will read the links and let you know
0
Nick RhodeIT DirectorCommented:
I would upgrade to Service Pack 2 or even 3.  Service Pack 1 in my opinion was garbage and had various issues.
0
OZSGGeneral Manager Technical ServicesAuthor Commented:
ok I made the change to the sync config file and will see if that did the trick. As of now all IIS Timeout settings on the server are set to 30mins. Firewall is still set at 1Hour or at least thats what he tells me.
0
OZSGGeneral Manager Technical ServicesAuthor Commented:
Perfect that did the trick.  Thanks for that.  I have been looking for ages for this fix and all were pointing to the IIS time out setting.  This is definitely a breakthrough.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.