Exchange 2010 Internet Connector FQDN still showing internal hostname

Posted on 2013-09-26
Medium Priority
Last Modified: 2013-10-01
I've having e-mails bounce to certain e-mail addresses because RDNS isn't setup correctly. Even though I've specified the correct hostname in the FQDN box, I still get bouncebacks saying my server has announced itself as servername.local instead of awebaddress.company.com

Is there anywhere else to set this other than just the send connector properties on Exchange 2010?

mx3.thewebsite.co.uk gave this error:
"E6:Mail rejected because server_address does not match Reverse DNS." 

Open in new window

Question by:tegenius

Accepted Solution

Nathan P earned 2000 total points
ID: 39524644
Reverse DNS is different to how your "Send Connector" advertises itself.

Let me try to explain.  Your "Send Connector", under Exchange, Organization Config, Hub Transport, Send Connectors tab - is a group of settings on the server itself, that tell the server how to act when communicating with other servers.

Your "Receive Connectors" under Exchange, Server Configuration, Hub Transport, Receive Connectors tab tells the server how to answer incoming queries.

Reverse DNS is something that the owner of your IP address space has to update.  Every IP address in the world can have a "Reverse DNS" record written for it, to determine who owns it or what it is..   You may need to call your ISP, or your networking guy, or your DNS company.. it's not a simple answer.

But in short, you need the internet to be able to check out the IP address your Exchange server responds on, and have the internet claim that it should be your mail servers address.

http://mxtoolbox.com/ReverseLookup.aspx  <--  Use this site to complete a Reverse DNS lookup.. As an example, if you put in, it will tell you it's Google's DNS server.

You need to be able to enter your IP address, and have the internet tell you its your server name.  

Again, Call your ISP, or your owner of your IP address space, and tell them you need to put in a Reverse DNS entry for the specific IP address in question.

Expert Comment

ID: 39524660
The external DNS name does not match the server response to EHLO when I check it from my Internet connection.  Please examine this TELNET, NSLOOKUP and PING dialogue below:

The email server EHLO response is saying its name is host,ariesnetworks.co.uk
The external DNS MX record says the name should be mail.thewebsite.co.uk
A reverse DNS lookup ping "-a option" to the IP address says the name is ds-90922.ds-10.com

Typically these names should match.  That may be one cause.  

Also, although you may be receiving email on, depending upon how your firewall is configured, outbound mail may actually be going out the default gateway of your router with a different IP address.  To check that open a browser on the email server and check it with whatismyipaddress.  Is that different?   Also, do you have an SPF record in external DNS?  You may have to set one up or it may be improperly configured.

220-host.ariesnetworks.co.uk ESMTP Exim 4.80.1 #2 Thu, 26 Sep 2013 14:27:13 +0100
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
500 unrecognized command
250-host.ariesnetworks.co.uk Hello  xxx
250-SIZE 52428800
250 HELP


> set type=MX
> thewebsite.co.uk

thewebsite.co.uk        MX preference = 10, mail exchanger = mail.thewebsite.co.
mail.thewebsite.co.uk   internet address =
> exit

C:\>ping -a

Pinging ds-90922.ds-10.com [] with 32 bytes of data:
Reply from bytes=32 time=189ms TTL=51

C:\>ping mx3.thewebsite.co.uk

Pinging mx3.thewebsite.co.uk [] with 32 bytes of data:
Reply from bytes=32 time=137ms TTL=51

LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39525570
Try the test as outlined here to confirm what is happening.

Another option would be to recreate the Send Connector. Don't forget to restart Transport after doing so.


Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

I am posting this in case anyone runs into similar issues that I did, this may save you a lot of grief: Condition: 1. Your NetBIOS domain name contains an ampersand " & " character.  (e.g. AT&T) 2. You've tried to run any Microsoft installation…
In my humble opinion (IMHO), TouchDown from Symantec is the best in class for this type of application, but Symantec has end-of-lifed it and although one can keep using it, it will no longer be supported or upgraded.  Time to look for alternatives t…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question