Exchange 2010 Internet Connector FQDN still showing internal hostname

I've having e-mails bounce to certain e-mail addresses because RDNS isn't setup correctly. Even though I've specified the correct hostname in the FQDN box, I still get bouncebacks saying my server has announced itself as servername.local instead of awebaddress.company.com

Is there anywhere else to set this other than just the send connector properties on Exchange 2010?

mx3.thewebsite.co.uk gave this error:
"E6:Mail rejected because server_address does not match Reverse DNS." 

Open in new window

tegeniusAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nathan PSystems ArchitectCommented:
Reverse DNS is different to how your "Send Connector" advertises itself.

Let me try to explain.  Your "Send Connector", under Exchange, Organization Config, Hub Transport, Send Connectors tab - is a group of settings on the server itself, that tell the server how to act when communicating with other servers.

Your "Receive Connectors" under Exchange, Server Configuration, Hub Transport, Receive Connectors tab tells the server how to answer incoming queries.

Reverse DNS is something that the owner of your IP address space has to update.  Every IP address in the world can have a "Reverse DNS" record written for it, to determine who owns it or what it is..   You may need to call your ISP, or your networking guy, or your DNS company.. it's not a simple answer.

But in short, you need the internet to be able to check out the IP address your Exchange server responds on, and have the internet claim that it should be your mail servers address.

http://mxtoolbox.com/ReverseLookup.aspx  <--  Use this site to complete a Reverse DNS lookup.. As an example, if you put in 8.8.8.8, it will tell you it's Google's DNS server.

You need to be able to enter your IP address, and have the internet tell you its your server name.  

Again, Call your ISP, or your owner of your IP address space, and tell them you need to put in a Reverse DNS entry for the specific IP address in question.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aa-denverCommented:
The external DNS name does not match the server response to EHLO when I check it from my Internet connection.  Please examine this TELNET, NSLOOKUP and PING dialogue below:

The email server EHLO response is saying its name is host,ariesnetworks.co.uk
The external DNS MX record says the name should be mail.thewebsite.co.uk
A reverse DNS lookup ping "-a option" to the IP address says the name is ds-90922.ds-10.com

Typically these names should match.  That may be one cause.  

Also, although you may be receiving email on 95.131.67.221, depending upon how your firewall is configured, outbound mail may actually be going out the default gateway of your router with a different IP address.  To check that open a browser on the email server and check it with whatismyipaddress.  Is that different?   Also, do you have an SPF record in external DNS?  You may have to set one up or it may be improperly configured.


220-host.ariesnetworks.co.uk ESMTP Exim 4.80.1 #2 Thu, 26 Sep 2013 14:27:13 +0100
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
ehlo
500 unrecognized command
EHLO
250-host.ariesnetworks.co.uk Hello  xxx
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP

C:\>nslookup

> set type=MX
> thewebsite.co.uk

thewebsite.co.uk        MX preference = 10, mail exchanger = mail.thewebsite.co.
uk
mail.thewebsite.co.uk   internet address = 95.131.67.221
> exit

C:\>ping -a 95.131.67.221

Pinging ds-90922.ds-10.com [95.131.67.221] with 32 bytes of data:
Reply from 95.131.67.221: bytes=32 time=189ms TTL=51

C:\>ping mx3.thewebsite.co.uk

Pinging mx3.thewebsite.co.uk [95.131.67.221] with 32 bytes of data:
Reply from 95.131.67.221: bytes=32 time=137ms TTL=51


C:\>
0
Simon Butler (Sembee)ConsultantCommented:
Try the test as outlined here to confirm what is happening.
http://cbl.abuseat.org/helocheck.htm

Another option would be to recreate the Send Connector. Don't forget to restart Transport after doing so.

Simon.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.