Switch doesn't like Ubuntu

I installed an unmanaged Cisco SG102-24 switch and it works great for Apple and Windows OS but not with Ubuntu. I can get a DHCP lease thru the switch from Win2k3 DC but I can't ping from the server to the machine or vice versa. The switch blocks all outgoing and incoming traffic to the Ubuntu machine except DHCP lease and Wireshark. Oddly enough I can see traffic running Wireshark from the machine but I can't ping any other machine on the network and I have no internet access either. Ubuntu 12.04.3 Precise Pangolin
LVL 9
jmac44Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dipopoCommented:
Have not worked with Ubuntu for some time now but would check iptables on the machine first.
jmac44Author Commented:
dipopo - firewall is disable.
Dave BaldwinFixer of ProblemsCommented:
I wouldn't be looking at the OS but at the details.  I have 7 generations of DOS and Windows, 3 generations of Mac, and 3 different Linux machines all running on the same network without any OS issues.  I do have one 10baseT network card that doesn't like a 1GB network card on another machine...
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Craig BeckCommented:
Have you tried the same Ubuntu machine with a different switch?

If the switch is unmanaged there's nothing on the switch to stop the Ubuntu machine working.
Fred MarshallPrincipalCommented:
Sounds very much like an IP address or subnet mask issue or gateway issue.
Since the Ubuntu is the odd man out, check there.
jmac44Author Commented:
Craig - I had to reinstate the old cisco catalyst 500 managed switch for that machine. I haven't tried it with a different unmanaged switch
jmac44Author Commented:
Marshall - first thing I checked was an IP conflict with DHCP and found none. This machine has been running on the network solid for a year so I don't think that's the issue. The only thing that changed was the switch. Thanks for the suggestion.
arnoldCommented:
What network card is in the ubuntu system?
there might be an issue/conflict between the network card and the auto-negotiation for speed/duplex.

Can anything and everything be accessed from the ubuntu system?

netstat -rn to see the routing table on the system.
sanjayrajtCommented:
Hi,
Can you try manual configuration of IP address and check your LAN driver installed correctly?.

try to ping 127.0.0.1
Craig BeckCommented:
I would try manually setting the speed and duplex settings on the machine then.
arnoldCommented:
With an unmanaged switch, leave it t auto-negotiate.
Please pot the output of netstat -rn
Output of iptables -t nat -L --line-numbers
Craig BeckCommented:
Hmmm, I still say 'try' it!  Never dismiss simple things just because you think it won't be that.
arnoldCommented:
The impression I am getting is that the system gets an IP via dhcp but is not routing.
Or the IP request fails an a DHCP un reachable IP is assigned.
Fred MarshallPrincipalCommented:
Another thought:
Modern switches are "smart" in that they route packets from one port to another without blocking communication between other port-pairs.  The MAC addresses are used to do this.  

So, is it possible that the Ubuntu system somehow has the same MAC address as another host on the network?  Likely a long shot but worth mentioning at least.
arnoldCommented:
ifconfig -a

The MAC address is "configurable".

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmac44Author Commented:
Thanks for all the suggestions. It turns out it was the port role on the down stream managed switch the unmanaged switch is connected to. It was set to switch and should have been set to a generic role. Still not clear why Ubuntu was only affected but there it is. One good reason to ditch managed switches - what a pain in the @55 for so little pay off.
jmac44Author Commented:
I awarded everyone that participated even though none had the solution. I think that's fair.
Dave BaldwinFixer of ProblemsCommented:
Thanks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.