XAMMP Service stopped

I found that I have lost my XAMMP connection.

I do not have IIS installed
I do not have Skype installed
I am using XP

I went to services and I found XAMMP Service is not running although set on automatic. I tried to restart but it come up with the message
The XAMMP service on the local computer started and then stopped.

I notice that if I type localhost in a browser I get to localhost/xammp correctly and if I click Status I see
SMTP service is Deactivated
FTP service is Deactivated
Tomcat service is Deactivated

All others are activated
I did check and my ftp software Core FTP seems to be running.

Any ideas are very welcome.

Thanks

John
johnhardyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
I notice that if I type localhost in a browser I get to localhost/xammp correctly
That means it's running or at least the web site is running.  None of the others things have to run for XAMPP to run and CoreFTP has nothing to do with XAMPP, it is a completely different program.
johnhardyAuthor Commented:
Thanks for the help Dave,
I tried another site on localhost and that's OK.

I tried in a browser localhost/mydomain and received message

 Access denied for user 'root@127.0.0.1'@'localhost' (using password: YES) in C:\xampp\htdocs\mydomain\Connections\PowerCMSConnection.php on line 9

Fatal error: Access denied for user 'root@127.0.0.1'@'localhost' (using password: YES) in C:\xampp\htdocs\mydomain\Connections\PowerCMSConnection.php on line 9

The connection code is
$hostname_PowerCMSConnection = "localhost";
$database_PowerCMSConnection = "mydomain";
$username_PowerCMSConnection = "root@127.0.0.1";
$password_PowerCMSConnection = "mypassword";
$PowerCMSConnection = mysql_pconnect($hostname_PowerCMSConnection, $username_PowerCMSConnection, $password_PowerCMSConnection) or trigger_error(mysql_error(),E_USER_ERROR);

I cannot see anything wrong there, maybe my eyes are not so sharp!
johnhardyAuthor Commented:
Just a bit more info I attach an image

Lock
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Dave BaldwinFixer of ProblemsCommented:
The username for MySQL would be "root", not "root@127.0.0.1".  And "127.0.0.1" is the same as "localhost" on most systems.  In a MySQL connection, you don't enter the IP address or domain name, MySQL reads that from the network connection request.  You just enter the username and password.

I haven't a clue about Navicat, I never use it.
johnhardyAuthor Commented:
Thanks Dave
I changed the username to root.

If I now open the index.php page with F12 from Dreamweaver i get the url address as file:///C:/xampp/htdocs/mydomain/index.php that shows just code.

If I open index.php with localhost/mydomain/ the correct page shows.

Any ideas?

Thanks

John
johnhardyAuthor Commented:
BTW
I opened some other index pages in other Dreamweaver sites on the machine and they open OK.
Dave BaldwinFixer of ProblemsCommented:
That's Dreamweaver's problem.  "file:///" means you are not opening the page thru the web server but as a regular file.  PHP requires you to open '*.php' files thru the web server for them to run thru the PHP interpreter and display properly.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnhardyAuthor Commented:
Hello Dave
Yes you are right.

Somehow the server connection had been completely lost.
I have no idea how. It was working OK so must have been in existence previously.

Anyway all seems OK now
Thanks
John
johnhardyAuthor Commented:
Thanks for the great help.
Regards

john
Dave BaldwinFixer of ProblemsCommented:
You're welcome, glad to help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.